summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Henrik Bruhn2020-01-16 20:09:10 +0100
committerJan-Henrik Bruhn2020-01-16 20:09:10 +0100
commit0aac8cfad20e7ddeabe6aa00d7628362beb97616 (patch)
tree99ff0dfbf549874a0d700158668707b70e0bb05a
downloadaur-0aac8cfad20e7ddeabe6aa00d7628362beb97616.tar.gz
Initial commit of ros melodic mbf_msgs
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD67
2 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..828b50fe8a73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ros-melodic-mbf-msgs
+ pkgdesc = ROS - The move_base_flex messages package providing the action definition files for the action GetPath, ExePath, Recovery and MoveBase.
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = 3-Clause BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-message-generation
+ makedepends = ros-melodic-nav-msgs
+ makedepends = ros-melodic-message-runtime
+ makedepends = ros-melodic-genmsg
+ makedepends = ros-melodic-geometry-msgs
+ makedepends = ros-melodic-std-msgs
+ makedepends = ros-melodic-actionlib-msgs
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-nav-msgs
+ depends = ros-melodic-message-runtime
+ depends = ros-melodic-geometry-msgs
+ depends = ros-melodic-std-msgs
+ depends = ros-melodic-actionlib-msgs
+ source = ros-melodic-mbf-msgs-0.2.5.tar.gz::https://github.com/uos-gbp/move_base_flex-release/archive/release/melodic/mbf_msgs/0.2.5.tar.gz
+ sha256sums = 603939164770a585198e17467e10dd17862d11a7f1ec7af8dbdee5041d29f027
+
+pkgname = ros-melodic-mbf-msgs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85a2d38b6123
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Script generated with create_pkgbuild.py
+ # For more information: https://github.com/ros-melodic-arch/ros-build-tools-py3
+ pkgdesc="ROS - The move_base_flex messages package providing the action definition files for the action GetPath, ExePath, Recovery and MoveBase."
+ url='http://www.ros.org/'
+
+ pkgname='ros-melodic-mbf-msgs'
+ pkgver='0.2.5'
+ arch=('any')
+ pkgrel=1
+ license=('3-Clause BSD')
+
+ ros_makedepends=(ros-melodic-message-generation
+ ros-melodic-nav-msgs
+ ros-melodic-message-runtime
+ ros-melodic-genmsg
+ ros-melodic-geometry-msgs
+ ros-melodic-std-msgs
+ ros-melodic-actionlib-msgs
+ ros-melodic-catkin)
+ makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ )
+
+ ros_depends=(ros-melodic-nav-msgs
+ ros-melodic-message-runtime
+ ros-melodic-geometry-msgs
+ ros-melodic-std-msgs
+ ros-melodic-actionlib-msgs)
+ depends=(${ros_depends[@]}
+ )
+
+ # Tarball version (faster download)
+ _dir="move_base_flex-release-release-melodic-mbf_msgs"
+ source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/uos-gbp/move_base_flex-release/archive/release/melodic/mbf_msgs/${pkgver}.tar.gz")
+ sha256sums=('603939164770a585198e17467e10dd17862d11a7f1ec7af8dbdee5041d29f027')
+
+ build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_ENABLE_TESTING=0 \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+ }
+
+ package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+ }
+ \ No newline at end of file