summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242019-05-12 12:42:23 +0000
committerbionade242019-05-12 12:42:23 +0000
commit8f4e67da09f9fa9f7aba03093b07e22a4c2f30e1 (patch)
tree0e1550172dc931c620d69bb2ce9d81864e79cbcc
parent9d66696c4f46c19cf0477f7d8190f68f50c4ebaf (diff)
downloadaur-8f4e67da09f9fa9f7aba03093b07e22a4c2f30e1.tar.gz
Update version and changed source to official ROS releases
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab171d4ca50f..e352447551c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ros-melodic-message-filters
pkgdesc = ROS - A set of message filters which take in messages and may output those messages at a later time, based on the conditions that filter needs met.
- pkgver = 1.14.3
+ pkgver = 1.12.14
pkgrel = 1
url = http://ros.org/wiki/message_filters
arch = any
@@ -15,8 +15,9 @@ pkgbase = ros-melodic-message-filters
makedepends = boost
depends = ros-melodic-rosconsole
depends = ros-melodic-roscpp
- source = ros-melodic-message-filters-1.14.3-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/message_filters/1.14.3-0.tar.gz
- sha256sums = 3eb38ff43701662023ac5e7141fb50303fb27657822275b4d4da92ed661ff72d
+ conflicts = ros-melodic-message-filters-git
+ source = ros-melodic-message-filters-1.12.14.tar.gz::https://github.com/ros/ros_comm/archive/1.12.14.tar.gz
+ sha256sums = 239c225cc9b1613cc7f76daf73c182f991787b7cf601287cb6cc28957eeeec1d
pkgname = ros-melodic-message-filters
diff --git a/PKGBUILD b/PKGBUILD
index e1f7f0f94241..5a040df9f7c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,7 @@ pkgdesc="ROS - A set of message filters which take in messages and may output th
url='http://ros.org/wiki/message_filters'
pkgname='ros-melodic-message-filters'
-pkgver='1.14.3'
-_pkgver_patch=0
+pkgver='1.12.14'
arch=('any')
pkgrel=1
license=('BSD')
@@ -34,9 +33,13 @@ depends=(
${ros_depends[@]}
)
-_dir="ros_comm-release-release-melodic-message_filters"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/message_filters/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('3eb38ff43701662023ac5e7141fb50303fb27657822275b4d4da92ed661ff72d')
+conflicts=(
+ 'ros-melodic-message-filters-git'
+)
+
+_dir="ros_comm-${pkgver}/utilities/message_filters"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/ros_comm/archive/${pkgver}.tar.gz")
+sha256sums=('239c225cc9b1613cc7f76daf73c182f991787b7cf601287cb6cc28957eeeec1d')
build() {
# Use ROS environment variables.
@@ -49,6 +52,8 @@ build() {
# Fix Python2/Python3 conflicts.
/usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ #Workaround for boost signals
+ sed -i 's/signals//g' ${srcdir}/${_dir}/CMakeLists.txt
# Build the project.
cmake ${srcdir}/${_dir} \