summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGPereira2018-02-22 11:18:28 +0000
committerGPereira2018-02-22 11:18:28 +0000
commit95fa2b7b976d9b6ddf9bc48e6e4de9a5f1a5273f (patch)
treeb10c6a8ea8ea145a46d5b3b96f25b819ec378755
downloadaur-95fa2b7b976d9b6ddf9bc48e6e4de9a5f1a5273f.tar.gz
Initial Commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD65
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd4c5dc8eb2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ros-melodic-message-filters
+ pkgdesc = ROS - A set of message filters which take in messages and may output those messages at a later time, based on the conditions that filter needs met.
+ pkgver = 1.13.6
+ pkgrel = 1
+ url = http://ros.org/wiki/message_filters
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-rosconsole
+ makedepends = ros-melodic-rostest
+ makedepends = ros-melodic-roscpp
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-rosunit
+ makedepends = boost
+ depends = ros-melodic-rosconsole
+ depends = ros-melodic-roscpp
+ source = ros-melodic-message-filters-1.13.6-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/message_filters/1.13.6-0.tar.gz
+ sha256sums = e8ccadc62012bfc1dc99f7c8f6a730a3b86ceb146658097a12f9f4e034994955
+
+pkgname = ros-melodic-message-filters
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58eb923ec76b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - A set of message filters which take in messages and may output those messages at a later time, based on the conditions that filter needs met."
+url='http://ros.org/wiki/message_filters'
+
+pkgname='ros-melodic-message-filters'
+pkgver='1.13.6'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-rosconsole
+ ros-melodic-rostest
+ ros-melodic-roscpp
+ ros-melodic-catkin
+ ros-melodic-rosunit)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost)
+
+ros_depends=(ros-melodic-rosconsole
+ ros-melodic-roscpp)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/message_filters/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_comm-release-release-melodic-message_filters-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/message_filters/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('e8ccadc62012bfc1dc99f7c8f6a730a3b86ceb146658097a12f9f4e034994955')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}