summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242020-12-10 20:40:15 +0100
committerbionade242020-12-10 20:40:15 +0100
commitbf32ce6904706addc366f23e0f131890ea5ba9db (patch)
treec0de6e4e77909c184663c014b3c6d78c86a5375b
parent9b73c54dbc3a478d57529808ec82e4dc49f2b5ed (diff)
downloadaur-bf32ce6904706addc366f23e0f131890ea5ba9db.tar.gz
Hardcode Boost Version to 1.69
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d11e93beeb78..fc139eddf878 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-message-filters
pkgdesc = ROS - A set of message filters which take in messages and may output those messages at a later time, based on the conditions that filter needs met.
pkgver = 1.14.10
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.ros.org/message_filters
arch = i686
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = ros-melodic-message-filters
makedepends = ros-melodic-catkin
makedepends = ros-melodic-rosconsole
makedepends = ros-melodic-roscpp
- makedepends = boost
+ makedepends = boost1.69
depends = ros-melodic-rosconsole
depends = ros-melodic-roscpp
conflicts = ros-melodic-message-filters-git
diff --git a/PKGBUILD b/PKGBUILD
index 4329b6deb167..95fc0ed2b47c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ url='https://wiki.ros.org/message_filters'
pkgname='ros-melodic-message-filters'
pkgver='1.14.10'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(
@@ -21,7 +21,7 @@ makedepends=(
'cmake'
'ros-build-tools'
${ros_makedepends[@]}
- boost
+ boost1.69
)
ros_depends=(
@@ -52,7 +52,7 @@ build() {
# Fix Python2/Python3 conflicts.
/usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- #Workaround for boost signals
+ #Workaround for boost1.69 signals
sed -i 's/signals//g' ${srcdir}/${_dir}/CMakeLists.txt
# Build the project.
@@ -61,7 +61,8 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DBOOST_ROOT=/opt/boost1.69
make
}