summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242019-05-12 12:54:34 +0000
committerbionade242019-05-12 12:54:34 +0000
commitdf3d70ef7586895bcd6a7bce9a67a1f717f83ba1 (patch)
treecfacf800957b89d341c598ed4c70eb59998f15c2
downloadaur-df3d70ef7586895bcd6a7bce9a67a1f717f83ba1.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD78
2 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc471971b033
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ros-melodic-message-filters-git
+ pkgdesc = ROS - A set of message filters which take in messages and may output those messages at a later time, based on the conditions that filter needs met.
+ pkgver = 29053c4
+ pkgrel = 1
+ url = http://ros.org/wiki/message_filters
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-rostest
+ makedepends = ros-melodic-rosunit
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-rosconsole
+ makedepends = ros-melodic-roscpp
+ makedepends = boost
+ depends = ros-melodic-rosconsole
+ depends = ros-melodic-roscpp
+ provides = ros-melodic-message-filters
+ conflicts = ros-melodic-message-filters
+ source = git+https://github.com/ros/ros_comm.git
+ sha256sums = SKIP
+
+pkgname = ros-melodic-message-filters-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aaf607c38876
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
+pkgdesc="ROS - A set of message filters which take in messages and may output those messages at a later time, based on the conditions that filter needs met."
+url='http://ros.org/wiki/message_filters'
+
+pkgname='ros-melodic-message-filters-git'
+pkgver='29053c4'
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(
+ ros-melodic-rostest
+ ros-melodic-rosunit
+ ros-melodic-catkin
+ ros-melodic-rosconsole
+ ros-melodic-roscpp
+)
+
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost
+)
+
+ros_depends=(
+ ros-melodic-rosconsole
+ ros-melodic-roscpp
+)
+
+depends=(
+ ${ros_depends[@]}
+)
+
+provides=(
+ 'ros-melodic-message-filters'
+)
+
+conflicts=(
+ 'ros-melodic-message-filters'
+)
+
+_dir="ros_comm/utilities/message_filters"
+source=("git+https://github.com/ros/ros_comm.git")
+sha256sums=('SKIP')
+
+build() {
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ #Workaround for boost signals
+ sed -i 's/signals//g' ${srcdir}/${_dir}/CMakeLists.txt
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}