summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-11-28 20:00:25 -0500
committeracxz2019-11-28 20:00:25 -0500
commit56e3864d6589dc2cadde164884ffc8460e360c73 (patch)
treef3e3df0f0f12713631664c3165ed6170faa31a91
downloadaur-56e3864d6589dc2cadde164884ffc8460e360c73.tar.gz
initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD76
2 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08bb0c2f5a57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = ros-melodic-navigation
+ pkgdesc = ROS - A 2D navigation stack that takes in information from odometry, sensor streams, and a goal pose and outputs safe velocity commands that are sent to a mobile base.
+ pkgver = 1.16.3
+ pkgrel = 1
+ url = https://wiki.ros.org/navigation
+ arch = any
+ license = BSD
+ license = LGPL
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-amcl
+ depends = ros-melodic-base-local-planner
+ depends = ros-melodic-carrot-planner
+ depends = ros-melodic-clear-costmap-recovery
+ depends = ros-melodic-costmap-2d
+ depends = ros-melodic-dwa-local-planner
+ depends = ros-melodic-fake-localization
+ depends = ros-melodic-global-planner
+ depends = ros-melodic-map-server
+ depends = ros-melodic-move-base
+ depends = ros-melodic-move-slow-and-clear
+ depends = ros-melodic-navfn
+ depends = ros-melodic-nav-core
+ depends = ros-melodic-rotate-recovery
+ depends = ros-melodic-voxel-grid
+ source = ros-melodic-navigation-1.16.3.tar.gz::https://github.com/ros-planning/navigation/archive/1.16.3.tar.gz
+ sha256sums = 23a6f3202fec00b07bb419453eed2591dd63fffa5da2fc78fb29620c9f2bdced
+
+pkgname = ros-melodic-navigation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf7c2c0e44a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+pkgdesc="ROS - A 2D navigation stack that takes in information from odometry,
+sensor streams, and a goal pose and outputs safe velocity commands that are sent
+to a mobile base."
+url='https://wiki.ros.org/navigation'
+
+pkgname='ros-melodic-navigation'
+pkgver='1.16.3'
+arch=('any')
+pkgrel=1
+license=('BSD' 'LGPL')
+
+ros_makedepends=(
+ ros-melodic-catkin
+)
+
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
+
+ros_depends=(
+ ros-melodic-amcl
+ ros-melodic-base-local-planner
+ ros-melodic-carrot-planner
+ ros-melodic-clear-costmap-recovery
+ ros-melodic-costmap-2d
+ ros-melodic-dwa-local-planner
+ ros-melodic-fake-localization
+ ros-melodic-global-planner
+ ros-melodic-map-server
+ ros-melodic-move-base
+ ros-melodic-move-slow-and-clear
+ ros-melodic-navfn
+ ros-melodic-nav-core
+ ros-melodic-rotate-recovery
+ ros-melodic-voxel-grid
+)
+
+depends=(
+ ${ros_depends[@]}
+)
+
+_dir="navigation-${pkgver}/navigation"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-planning/navigation/archive/${pkgver}.tar.gz")
+sha256sums=('23a6f3202fec00b07bb419453eed2591dd63fffa5da2fc78fb29620c9f2bdced')
+
+build() {
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}