summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTassos (nakano) Natsakis2019-01-30 17:14:50 +0200
committerTassos (nakano) Natsakis2019-01-30 17:14:50 +0200
commit79fdf54fbca3ebd9a4d8a27a6bb8e68a15690a60 (patch)
tree29b79d05bcad666dad9aaa749aa859be667f239c
parentdc39e6ac366c8655ca83fd33b76ef4b907805445 (diff)
downloadaur-79fdf54fbca3ebd9a4d8a27a6bb8e68a15690a60.tar.gz
Updating requirement for python3.7
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fa23fded4e0..79cb1d1d5453 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-openni-launch
pkgdesc = ROS - Drivers for the Microsoft Kinect, Asus Xtion, and Primesense Devices.
pkgver = 1.11.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.ros.org/
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 188a8ffadf96..2100689d8196 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-melodic-openni-launch'
pkgver='1.11.0'
_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-melodic-nodelet
@@ -44,17 +44,17 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}