summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:39:00 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:39:00 +0100
commit9e38229e9ce1e2c83b19e5e571c3cb6d5e2137ed (patch)
tree3a752a2986d3532a9bf9b465b0a661411c06c04e
downloadaur-9e38229e9ce1e2c83b19e5e571c3cb6d5e2137ed.tar.gz
Update
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD61
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54af0a69df53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ros-melodic-perception-pcl
+ pkgdesc = ROS - PCL (Point Cloud Library) ROS interface stack.
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = http://ros.org/wiki/perception_pcl
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-pcl-conversions
+ depends = ros-melodic-pcl-ros
+ depends = ros-melodic-pcl-msgs
+ source = ros-melodic-perception-pcl-1.6.1-0.tar.gz::https://github.com/ros-gbp/perception_pcl-release/archive/release/melodic/perception_pcl/1.6.1-0.tar.gz
+ sha256sums = 4ef871f17d78e4816ca81c3fd31aea8dbe093a992027292ead7daecdf81cde4e
+
+pkgname = ros-melodic-perception-pcl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3f0c9c30486
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - PCL (Point Cloud Library) ROS interface stack."
+url='http://ros.org/wiki/perception_pcl'
+
+pkgname='ros-melodic-perception-pcl'
+pkgver='1.6.1'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-pcl-conversions
+ ros-melodic-pcl-ros
+ ros-melodic-pcl-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/perception_pcl/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/perception_pcl-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="perception_pcl-release-release-melodic-perception_pcl-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/perception_pcl-release/archive/release/melodic/perception_pcl/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('4ef871f17d78e4816ca81c3fd31aea8dbe093a992027292ead7daecdf81cde4e')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}