summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 14:56:11 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 14:56:11 +0200
commit996c21bfc3780934e81c0041af5ff0d3164c2ac0 (patch)
treec1bb91b3152c4ad61794b3cf28ae9685f1f9a203
parentdb9152671a945443a3ff30edd0274d6afd8d3c86 (diff)
downloadaur-996c21bfc3780934e81c0041af5ff0d3164c2ac0.tar.gz
Update!
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD107
2 files changed, 68 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7eb540061272..5bcc72736215 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = ros-melodic-qt-gui-cpp
pkgdesc = ROS - qt_gui_cpp provides the foundation for C++-bindings for qt_gui and creates bindings for every generator available.
- pkgver = 0.3.9
+ pkgver = 0.3.11
pkgrel = 1
url = http://ros.org/wiki/qt_gui_cpp
arch = any
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-pluginlib
- makedepends = ros-melodic-catkin
makedepends = ros-melodic-python-qt-binding
+ makedepends = ros-melodic-catkin
makedepends = ros-melodic-cmake-modules
+ makedepends = ros-melodic-pluginlib
makedepends = tinyxml
- makedepends = qt5-base
makedepends = pkg-config
- depends = ros-melodic-pluginlib
+ makedepends = qt5-base
depends = ros-melodic-qt-gui
+ depends = ros-melodic-pluginlib
depends = tinyxml
- source = ros-melodic-qt-gui-cpp-0.3.9-0.tar.gz::https://github.com/ros-gbp/qt_gui_core-release/archive/release/melodic/qt_gui_cpp/0.3.9-0.tar.gz
- sha256sums = 503ed11486b3422e0c86e7e9235c53dabdd4384a60a42370984747522f97a744
+ source = ros-melodic-qt-gui-cpp::git+https://github.com/ros-gbp/qt_gui_core-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-qt-gui-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 05fc2ccbffbd..98fc0e18b2c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,67 +1,82 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - qt_gui_cpp provides the foundation for C++-bindings for qt_gui and creates bindings for every generator available."
url='http://ros.org/wiki/qt_gui_cpp'
pkgname='ros-melodic-qt-gui-cpp'
-pkgver='0.3.9'
+pkgver='0.3.11'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-pluginlib
- ros-melodic-catkin
- ros-melodic-python-qt-binding
- ros-melodic-cmake-modules)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- tinyxml
- qt5-base
- pkg-config)
+ros_makedepends=(
+ ros-melodic-python-qt-binding
+ ros-melodic-catkin
+ ros-melodic-cmake-modules
+ ros-melodic-pluginlib
+)
-ros_depends=(ros-melodic-pluginlib
- ros-melodic-qt-gui)
-depends=(${ros_depends[@]}
- tinyxml)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+ tinyxml
+ pkg-config
+ qt5-base
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/qt_gui_cpp/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/qt_gui_core-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-qt-gui
+ ros-melodic-pluginlib
+)
-# Tarball version (faster download)
-_dir="qt_gui_core-release-release-melodic-qt_gui_cpp-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/qt_gui_core-release/archive/release/melodic/qt_gui_cpp/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('503ed11486b3422e0c86e7e9235c53dabdd4384a60a42370984747522f97a744')
+depends=(
+ ${ros_depends[@]}
+ tinyxml
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/qt_gui_core-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}