summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-09-28 23:24:23 -0400
committeracxz2019-09-28 23:24:23 -0400
commitb9bd1807360dc49834522737d0dd6cce8f90cbd8 (patch)
treec572312b62a4055579485491fc2bfdf6f8991a70
parenta383cf51c29f95fca179dd034ec1160e916cd9af (diff)
downloadaur-b9bd1807360dc49834522737d0dd6cce8f90cbd8.tar.gz
update to python 3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 7 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 564e9592d17e..e231bf761b5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-random-numbers
pkgdesc = ROS - This library contains wrappers for generating floating point values, integers, quaternions using boost libraries.
pkgver = 0.3.2
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.ros.org/random_numbers
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 4637955a9be1..f1ae946cc048 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,8 @@ url='https://wiki.ros.org/random_numbers'
pkgname='ros-melodic-random-numbers'
pkgver='0.3.2'
-_pkgver_patch=0
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(ros-melodic-catkin)
@@ -19,13 +18,6 @@ ros_depends=()
depends=(${ros_depends[@]}
boost)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/random_numbers/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/random_numbers-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
-
-# Tarball version (faster download)
_dir="random_numbers-${pkgver}"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-planning/random_numbers/archive/${pkgver}.tar.gz")
sha256sums=('da825a0c7a4e9de180d9d539aa78682c1d805b1e4c3ef16af0e6cb384f2134f5')
@@ -40,17 +32,17 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}