summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-03-18 11:56:28 -0400
committerGitHub2020-03-18 11:56:28 -0400
commit7c44adb04dfe1c0a85d2a9c23808cff2952a3b3c (patch)
treed433c85f35bf1e3d34f96f089666082bf0bb3078
parent624b00025a444f6c665e650684a60c58a21b35ef (diff)
downloadaur-7c44adb04dfe1c0a85d2a9c23808cff2952a3b3c.tar.gz
patch for skipping tests (#6)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--tests.patch11
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54d832c41666..1109e52e422d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-realtime-tools
pkgdesc = ROS - Contains a set of tools that can be used from a hard realtime thread, without breaking the realtime behavior.
pkgver = 1.16.0
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.ros.org/realtime_tools
arch = i686
arch = x86_64
@@ -19,7 +19,9 @@ pkgbase = ros-melodic-realtime-tools
depends = ros-melodic-rostest
depends = ros-melodic-actionlib
source = ros-melodic-realtime-tools-1.16.0.tar.gz::https://github.com/ros-controls/realtime_tools/archive/1.16.0.tar.gz
+ source = tests.patch
sha256sums = 690222fd2908cec0412d20f6e8b5d8a17132d959edb719e01695e89f7c4d8111
+ sha256sums = d40ccadd950cbd5743295639bed2d0c1b0ab8a5edfac8f9de5cbf11a48ed8300
pkgname = ros-melodic-realtime-tools
diff --git a/PKGBUILD b/PKGBUILD
index f379ca869406..7ff20f28381d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ url='https://wiki.ros.org/realtime_tools'
pkgname='ros-melodic-realtime-tools'
pkgver='1.16.0'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(
@@ -25,8 +25,15 @@ ros_depends=(
depends=(${ros_depends[@]})
_dir="${srcdir}/realtime_tools-${pkgver}"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-controls/realtime_tools/archive/${pkgver}.tar.gz")
-sha256sums=('690222fd2908cec0412d20f6e8b5d8a17132d959edb719e01695e89f7c4d8111')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-controls/realtime_tools/archive/${pkgver}.tar.gz"
+ "tests.patch")
+sha256sums=('690222fd2908cec0412d20f6e8b5d8a17132d959edb719e01695e89f7c4d8111'
+ 'd40ccadd950cbd5743295639bed2d0c1b0ab8a5edfac8f9de5cbf11a48ed8300')
+
+prepare() {
+ cd "${srcdir}/${_dir}"
+ patch -uN CMakeLists.txt ../../tests.patch || return 1
+}
build() {
# Use ROS environment variables
diff --git a/tests.patch b/tests.patch
new file mode 100644
index 000000000000..b3705be592b6
--- /dev/null
+++ b/tests.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2020-03-15 18:05:20.022844807 -0400
++++ CMakeLists.txt 2020-03-15 18:05:35.495900511 -0400
+@@ -19,7 +19,7 @@
+ target_include_directories(${PROJECT_NAME} PUBLIC ${catkin_INCLUDE_DIRS})
+
+ # Unit Tests
+-if (CATKIN_ENABLE_TESTING)
++if (CATKIN_ENABLE_TESTING AND (EXISTS ${GMOCK_MAIN_LIBRARIES}))
+ catkin_add_gmock(realtime_box_tests test/realtime_box_tests.cpp)
+ target_link_libraries(realtime_box_tests ${PROJECT_NAME} ${GMOCK_MAIN_LIBRARIES})
+