summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:48:28 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:48:28 +0100
commit90d6b28ffe2fc2f46ef29f48a719185ba7ec5603 (patch)
treea3d0c6986a863fb2c77217b358041d3dc42bd5db
downloadaur-90d6b28ffe2fc2f46ef29f48a719185ba7ec5603.tar.gz
Update
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD62
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a145bb4f2dc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ros-melodic-realtime-tools
+ pkgdesc = ROS - Contains a set of tools that can be used from a hard realtime thread, without breaking the realtime behavior.
+ pkgver = 1.11.0
+ pkgrel = 1
+ url = http://ros.org/wiki/realtime_tools
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-roscpp
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-rospy
+ depends = ros-melodic-roscpp
+ depends = ros-melodic-rospy
+ source = ros-melodic-realtime-tools-1.11.0-0.tar.gz::https://github.com/ros-gbp/realtime_tools-release/archive/release/melodic/realtime_tools/1.11.0-0.tar.gz
+ sha256sums = 4569e54e969244f82c470950995591f6437b024a08947eab22a20371c60f108e
+
+pkgname = ros-melodic-realtime-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba42164df610
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Contains a set of tools that can be used from a hard realtime thread, without breaking the realtime behavior."
+url='http://ros.org/wiki/realtime_tools'
+
+pkgname='ros-melodic-realtime-tools'
+pkgver='1.11.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-roscpp
+ ros-melodic-catkin
+ ros-melodic-rospy)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-roscpp
+ ros-melodic-rospy)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/realtime_tools/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/realtime_tools-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="realtime_tools-release-release-melodic-realtime_tools-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/realtime_tools-release/archive/release/melodic/realtime_tools/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('4569e54e969244f82c470950995591f6437b024a08947eab22a20371c60f108e')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}