summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:30:43 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:30:43 +0200
commit430236e2a63dd0379ea4349e9dce221dafde7a65 (patch)
tree4a9d6f67a5e540d8f4b6d5826c4f0ac9791f018a
parentc9e85a4db535b0b3d8c4b137734f30afa810b761 (diff)
downloadaur-430236e2a63dd0379ea4349e9dce221dafde7a65.tar.gz
Update
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD109
2 files changed, 56 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12e1738db4bd..88773dc0c5e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,19 +8,19 @@ pkgbase = ros-melodic-ros
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
- depends = ros-melodic-rosclean
- depends = ros-melodic-rosboost-cfg
- depends = ros-melodic-catkin
+ depends = ros-melodic-rosmake
depends = ros-melodic-roscreate
- depends = ros-melodic-roslib
+ depends = ros-melodic-rosunit
depends = ros-melodic-mk
- depends = ros-melodic-rosbuild
depends = ros-melodic-roslang
- depends = ros-melodic-rosmake
+ depends = ros-melodic-catkin
+ depends = ros-melodic-roslib
+ depends = ros-melodic-rosboost-cfg
+ depends = ros-melodic-rosclean
+ depends = ros-melodic-rosbuild
depends = ros-melodic-rosbash
- depends = ros-melodic-rosunit
- source = ros-melodic-ros::git+https://github.com/ros-gbp/ros-release.git
- sha256sums = SKIP
+ source = ros-melodic-ros-1.14.4-0.tar.gz::https://github.com/ros-gbp/ros-release/archive/release/melodic/ros/1.14.4-0.tar.gz
+ sha256sums = cefa18dd07377c6b6fd8007af8b6744c82deba139bf3a2219d6c3927ba95edaa
pkgname = ros-melodic-ros
diff --git a/PKGBUILD b/PKGBUILD
index 6ee640386e1d..c6b673ef914e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - ROS packaging system."
url='http://www.ros.org/wiki/ROS'
@@ -10,75 +10,60 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-catkin
-)
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-rosmake
+ ros-melodic-roscreate
+ ros-melodic-rosunit
+ ros-melodic-mk
+ ros-melodic-roslang
+ ros-melodic-catkin
+ ros-melodic-roslib
+ ros-melodic-rosboost-cfg
+ ros-melodic-rosclean
+ ros-melodic-rosbuild
+ ros-melodic-rosbash)
+depends=(${ros_depends[@]})
-ros_depends=(
- ros-melodic-rosclean
- ros-melodic-rosboost-cfg
- ros-melodic-catkin
- ros-melodic-roscreate
- ros-melodic-roslib
- ros-melodic-mk
- ros-melodic-rosbuild
- ros-melodic-roslang
- ros-melodic-rosmake
- ros-melodic-rosbash
- ros-melodic-rosunit
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/ros/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="ros-release-release-melodic-ros-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros-release/archive/release/melodic/ros/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('cefa18dd07377c6b6fd8007af8b6744c82deba139bf3a2219d6c3927ba95edaa')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}