summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:35:56 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:35:56 +0100
commit6f80d2b3810e53a5ceb84aeba9a96d2962f4ca81 (patch)
treeb4d31eba34525b9aa28d3b60339dd4e946d7d62e
downloadaur-6f80d2b3810e53a5ceb84aeba9a96d2962f4ca81.tar.gz
Update
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD79
2 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a11f51476f4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = ros-melodic-ros-core
+ pkgdesc = ROS - A metapackage to aggregate the packages required to use publish / subscribe, services, launch files, and other core ROS concepts.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-ros
+ depends = ros-melodic-genmsg
+ depends = ros-melodic-rospack
+ depends = ros-melodic-ros-comm
+ depends = ros-melodic-common-msgs
+ depends = ros-melodic-gencpp
+ depends = ros-melodic-std-msgs
+ depends = ros-melodic-geneus
+ depends = ros-melodic-rosgraph-msgs
+ depends = ros-melodic-message-runtime
+ depends = ros-melodic-catkin
+ depends = ros-melodic-rosconsole-bridge
+ depends = ros-melodic-roscpp-core
+ depends = ros-melodic-gennodejs
+ depends = ros-melodic-genlisp
+ depends = ros-melodic-std-srvs
+ depends = ros-melodic-rosbag-migration-rule
+ depends = ros-melodic-roslisp
+ depends = ros-melodic-message-generation
+ depends = ros-melodic-genpy
+ depends = ros-melodic-cmake-modules
+ source = ros-melodic-ros-core-1.4.0-0.tar.gz::https://github.com/ros-gbp/metapackages-release/archive/release/melodic/ros_core/1.4.0-0.tar.gz
+ sha256sums = e61588bc3394e2c9cf2057c50e106ba54e1dbd1756f8c1e0433e3b0d4d54f9c2
+
+pkgname = ros-melodic-ros-core
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40f179e16f66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - A metapackage to aggregate the packages required to use publish / subscribe, services, launch files, and other core ROS concepts."
+url='http://www.ros.org/'
+
+pkgname='ros-melodic-ros-core'
+pkgver='1.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-ros
+ ros-melodic-genmsg
+ ros-melodic-rospack
+ ros-melodic-ros-comm
+ ros-melodic-common-msgs
+ ros-melodic-gencpp
+ ros-melodic-std-msgs
+ ros-melodic-geneus
+ ros-melodic-rosgraph-msgs
+ ros-melodic-message-runtime
+ ros-melodic-catkin
+ ros-melodic-rosconsole-bridge
+ ros-melodic-roscpp-core
+ ros-melodic-gennodejs
+ ros-melodic-genlisp
+ ros-melodic-std-srvs
+ ros-melodic-rosbag-migration-rule
+ ros-melodic-roslisp
+ ros-melodic-message-generation
+ ros-melodic-genpy
+ ros-melodic-cmake-modules)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/ros_core/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/metapackages-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="metapackages-release-release-melodic-ros_core-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/metapackages-release/archive/release/melodic/ros_core/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('e61588bc3394e2c9cf2057c50e106ba54e1dbd1756f8c1e0433e3b0d4d54f9c2')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}