summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 14:57:33 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 14:57:33 +0200
commitfcdb6056cace21312a7c4350ed6e4fe019b25774 (patch)
tree85c8d5d6e90c3e17854dfb84cccdeb86d7c5c633
parent25d9930c2bd05b48a5445d9db85889e4632de4ac (diff)
downloadaur-fcdb6056cace21312a7c4350ed6e4fe019b25774.tar.gz
Update!
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD135
2 files changed, 93 insertions, 78 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a437785f813e..9dbe814327dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,32 +8,32 @@ pkgbase = ros-melodic-ros-core
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
- depends = ros-melodic-ros
- depends = ros-melodic-ros-comm
+ depends = ros-melodic-message-generation
+ depends = ros-melodic-cmake-modules
depends = ros-melodic-geneus
depends = ros-melodic-rosgraph-msgs
- depends = ros-melodic-gennodejs
- depends = ros-melodic-genlisp
- depends = ros-melodic-std-srvs
depends = ros-melodic-roslisp
- depends = ros-melodic-roscpp-core
- depends = ros-melodic-rosconsole
+ depends = ros-melodic-rosconsole-bridge
+ depends = ros-melodic-genpy
+ depends = ros-melodic-message-runtime
+ depends = ros-melodic-std-srvs
depends = ros-melodic-genmsg
- depends = ros-melodic-gencpp
- depends = ros-melodic-std-msgs
+ depends = ros-melodic-rospack
depends = ros-melodic-catkin
- depends = ros-melodic-pluginlib
+ depends = ros-melodic-ros-comm
+ depends = ros-melodic-rosconsole
depends = ros-melodic-class-loader
- depends = ros-melodic-rospack
- depends = ros-melodic-cmake-modules
depends = ros-melodic-common-msgs
- depends = ros-melodic-message-runtime
- depends = ros-melodic-rosconsole-bridge
- depends = ros-melodic-genpy
+ depends = ros-melodic-genlisp
+ depends = ros-melodic-ros
+ depends = ros-melodic-std-msgs
+ depends = ros-melodic-roscpp-core
+ depends = ros-melodic-pluginlib
depends = ros-melodic-rosbag-migration-rule
- depends = ros-melodic-message-generation
- source = ros-melodic-ros-core-1.4.1-0.tar.gz::https://github.com/ros-gbp/metapackages-release/archive/release/melodic/ros_core/1.4.1-0.tar.gz
- sha256sums = 390d24da9397fce3a11f1dc7a0a23fb0886b81a4cfd2473906508358a670782d
+ depends = ros-melodic-gencpp
+ depends = ros-melodic-gennodejs
+ source = ros-melodic-ros-core::git+https://github.com/ros-gbp/metapackages-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-ros-core
diff --git a/PKGBUILD b/PKGBUILD
index 6b72e1344518..ea3dd20f56d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - A metapackage to aggregate the packages required to use publish / subscribe, services, launch files, and other core ROS concepts."
url='http://www.ros.org/'
@@ -10,73 +10,88 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-catkin
+)
-ros_depends=(ros-melodic-ros
- ros-melodic-ros-comm
- ros-melodic-geneus
- ros-melodic-rosgraph-msgs
- ros-melodic-gennodejs
- ros-melodic-genlisp
- ros-melodic-std-srvs
- ros-melodic-roslisp
- ros-melodic-roscpp-core
- ros-melodic-rosconsole
- ros-melodic-genmsg
- ros-melodic-gencpp
- ros-melodic-std-msgs
- ros-melodic-catkin
- ros-melodic-pluginlib
- ros-melodic-class-loader
- ros-melodic-rospack
- ros-melodic-cmake-modules
- ros-melodic-common-msgs
- ros-melodic-message-runtime
- ros-melodic-rosconsole-bridge
- ros-melodic-genpy
- ros-melodic-rosbag-migration-rule
- ros-melodic-message-generation)
-depends=(${ros_depends[@]})
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/ros_core/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/metapackages-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-message-generation
+ ros-melodic-cmake-modules
+ ros-melodic-geneus
+ ros-melodic-rosgraph-msgs
+ ros-melodic-roslisp
+ ros-melodic-rosconsole-bridge
+ ros-melodic-genpy
+ ros-melodic-message-runtime
+ ros-melodic-std-srvs
+ ros-melodic-genmsg
+ ros-melodic-rospack
+ ros-melodic-catkin
+ ros-melodic-ros-comm
+ ros-melodic-rosconsole
+ ros-melodic-class-loader
+ ros-melodic-common-msgs
+ ros-melodic-genlisp
+ ros-melodic-ros
+ ros-melodic-std-msgs
+ ros-melodic-roscpp-core
+ ros-melodic-pluginlib
+ ros-melodic-rosbag-migration-rule
+ ros-melodic-gencpp
+ ros-melodic-gennodejs
+)
-# Tarball version (faster download)
-_dir="metapackages-release-release-melodic-ros_core-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/metapackages-release/archive/release/melodic/ros_core/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('390d24da9397fce3a11f1dc7a0a23fb0886b81a4cfd2473906508358a670782d')
+depends=(
+ ${ros_depends[@]}
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/metapackages-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}