summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2019-01-09 19:33:34 +0100
committerGonçalo Camelo Neves Pereira2019-01-09 19:33:34 +0100
commit285dfbd246015b8d6faf0cb6346d3381fcaa34d0 (patch)
treeb623689ffe668e2743eb45b3d4cbc2793e76faf8
parent1f672d0f86079373577c535f365dae81c6dab153 (diff)
downloadaur-285dfbd246015b8d6faf0cb6346d3381fcaa34d0.tar.gz
New Version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD83
2 files changed, 45 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64b046b9a8ee..b3a09e2877aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,9 +8,9 @@ pkgbase = ros-melodic-rosgraph
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
- depends = python-rospkg
- depends = python-netifaces
depends = python-yaml
+ depends = python-netifaces
+ depends = python-rospkg
source = ros-melodic-rosgraph-1.14.3-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rosgraph/1.14.3-0.tar.gz
sha256sums = e17c523458f3ae9cd5f463da95034fa8cea78a17fffdf0f1d2921047b812205d
diff --git a/PKGBUILD b/PKGBUILD
index 5acc45f598ad..f637c1ef8043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - rosgraph contains the rosgraph command-line tool, which prints information about the ROS Computation Graph."
url='http://ros.org/wiki/rosgraph'
@@ -10,53 +10,56 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-catkin
+)
-ros_depends=()
-depends=(${ros_depends[@]}
- python-rospkg
- python-netifaces
- python-yaml)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/rosgraph/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+)
+
+depends=(
+ ${ros_depends[@]}
+ python-yaml
+ python-netifaces
+ python-rospkg
+)
-# Tarball version (faster download)
_dir="ros_comm-release-release-melodic-rosgraph-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rosgraph/${pkgver}-${_pkgver_patch}.tar.gz")
sha256sums=('e17c523458f3ae9cd5f463da95034fa8cea78a17fffdf0f1d2921047b812205d')
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}