summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLibor Wagner2020-05-21 10:54:27 +0200
committerGitHub2020-05-21 04:54:27 -0400
commitcd0f6b6930b211ff371391afe54dd98a9fb5b8ef (patch)
tree6de83b5bbf7561b6777047803fe95d48d6d6c783
parent1c5d6a6d6bcda550bb17cc643d7d8365b9bc25d0 (diff)
downloadaur-cd0f6b6930b211ff371391afe54dd98a9fb5b8ef.tar.gz
Fixing build problems (#2)
Co-authored-by: Libor Wagner <libor.wagner@cvut.cz>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--python38.patch17
3 files changed, 5 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13396c839dc5..ed3c1a700d0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-rosgraph
pkgdesc = ROS - rosgraph contains the rosgraph command-line tool, which prints information about the ROS Computation Graph.
pkgver = 1.14.5
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.ros.org/rosgraph
arch = any
license = BSD
@@ -12,9 +12,7 @@ pkgbase = ros-melodic-rosgraph
depends = python-netifaces
depends = python-rospkg
source = ros-melodic-rosgraph-1.14.5.tar.gz::https://github.com/ros/ros_comm/archive/1.14.5.tar.gz
- source = python38.patch
sha256sums = 49849315ca55247c656a5a50cd5caa5f33f7d212766ff09b62eae48f1dc6c3e7
- sha256sums = 57d5c7ad1638ba2bd4056a0be8ce15e681a77984b54c04a84799ef51c37e46c2
pkgname = ros-melodic-rosgraph
diff --git a/PKGBUILD b/PKGBUILD
index 6b10edbc7525..c9a4be9ce12e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ url='https://wiki.ros.org/rosgraph'
pkgname='ros-melodic-rosgraph'
pkgver='1.14.5'
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(
@@ -29,16 +29,9 @@ depends=(
python-rospkg
)
-_dir="ros_comm-${pkgver}/rosgraph"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/ros_comm/archive/${pkgver}.tar.gz"
- "python38.patch")
-sha256sums=('49849315ca55247c656a5a50cd5caa5f33f7d212766ff09b62eae48f1dc6c3e7'
- '57d5c7ad1638ba2bd4056a0be8ce15e681a77984b54c04a84799ef51c37e46c2')
-
-prepare() {
- cd "${srcdir}/${_dir}"
- patch -uN src/rosgraph/roslogging.py ../../../python38.patch || return 1
-}
+_dir="ros_comm-${pkgver}/tools/rosgraph"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/ros_comm/archive/${pkgver}.tar.gz")
+sha256sums=('49849315ca55247c656a5a50cd5caa5f33f7d212766ff09b62eae48f1dc6c3e7')
build() {
diff --git a/python38.patch b/python38.patch
deleted file mode 100644
index 932af17380f2..000000000000
--- a/python38.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/tools/rosgraph/src/rosgraph/roslogging.py
-+++ b/tools/rosgraph/src/rosgraph/roslogging.py
-@@ -49,12 +49,12 @@ from rospkg.environment import ROS_LOG_DIR
- class LoggingException(Exception): pass
-
- class RospyLogger(logging.getLoggerClass()):
-- def findCaller(self, dummy=False): # Dummy second arg to match Python3 function declaration
-+ def findCaller(self, *args, **kwargs):
- """
- Find the stack frame of the caller so that we can note the source
- file name, line number, and function name with class name if possible.
- """
-- file_name, lineno, func_name = super(RospyLogger, self).findCaller()[:3]
-+ file_name, lineno, func_name = super(RospyLogger, self).findCaller(*args, **kwargs)[:3]
-
- f = inspect.currentframe()
- if f is not None: