summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 14:58:16 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 14:58:16 +0200
commit3a0c183f64ae3a0775955a38bc523d04e604da10 (patch)
tree6788230e878a098155a4ae8a690974b0f51a56a1
parentc394ee434ce8f13ac81f142f8593fb2e1634834c (diff)
downloadaur-3a0c183f64ae3a0775955a38bc523d04e604da10.tar.gz
Update!
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD104
2 files changed, 61 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5758d5b26a35..6d6e4e017a93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,8 +12,8 @@ pkgbase = ros-melodic-rosgraph-msgs
makedepends = ros-melodic-std-msgs
depends = ros-melodic-message-runtime
depends = ros-melodic-std-msgs
- source = ros-melodic-rosgraph-msgs-1.11.2-1.tar.gz::https://github.com/ros-gbp/ros_comm_msgs-release/archive/release/melodic/rosgraph_msgs/1.11.2-1.tar.gz
- sha256sums = cc5dfe2ee766488d8aa0b55e081e9c6c817938e6e77dae09752b8943b93d1d57
+ source = ros-melodic-rosgraph-msgs::git+https://github.com/ros-gbp/ros_comm_msgs-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-rosgraph-msgs
diff --git a/PKGBUILD b/PKGBUILD
index b3876ccad4a3..42773bd095c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,77 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - Messages relating to the ROS Computation Graph."
url='http://ros.org/wiki/rosgraph_msgs'
pkgname='ros-melodic-rosgraph-msgs'
pkgver='1.11.2'
-_pkgver_patch=1
+_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-message-generation
- ros-melodic-catkin
- ros-melodic-std-msgs)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-message-generation
+ ros-melodic-catkin
+ ros-melodic-std-msgs
+)
-ros_depends=(ros-melodic-message-runtime
- ros-melodic-std-msgs)
-depends=(${ros_depends[@]})
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/rosgraph_msgs/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm_msgs-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-message-runtime
+ ros-melodic-std-msgs
+)
-# Tarball version (faster download)
-#_dir="ros_comm_msgs-release-release-melodic-rosgraph_msgs-${pkgver}-${_pkgver_patch}"
-_dir="ros_comm_msgs-release-release-melodic-rosgraph_msgs"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm_msgs-release/archive/release/melodic/rosgraph_msgs/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('cc5dfe2ee766488d8aa0b55e081e9c6c817938e6e77dae09752b8943b93d1d57')
+depends=(
+ ${ros_depends[@]}
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm_msgs-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
-
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}