summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGPereira2018-02-24 12:22:22 +0000
committerGPereira2018-02-24 12:22:22 +0000
commit79cd2ba7b0df250d63dcdc72eb5e48e19fb69a39 (patch)
tree95ef81ff6dcc7e0c8c324ed9a1981fd78d925dd5
downloadaur-79cd2ba7b0df250d63dcdc72eb5e48e19fb69a39.tar.gz
Initial Commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD64
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c37c1c80d66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ros-melodic-roslib
+ pkgdesc = ROS - Base dependencies and support libraries for ROS.
+ pkgver = 1.14.3
+ pkgrel = 1
+ url = http://ros.org/wiki/roslib
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-rospack
+ makedepends = ros-melodic-catkin
+ makedepends = boost
+ depends = ros-melodic-ros-environment
+ depends = ros-melodic-rospack
+ depends = ros-melodic-catkin
+ depends = python2-rospkg
+ source = ros-melodic-roslib-1.14.3-0.tar.gz::https://github.com/ros-gbp/ros-release/archive/release/melodic/roslib/1.14.3-0.tar.gz
+ sha256sums = ffea38338ce18f6e17824790aa5afbbe3b6af9f81dd81f889e5ac9347836754c
+
+pkgname = ros-melodic-roslib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..716beb78a271
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Base dependencies and support libraries for ROS."
+url='http://ros.org/wiki/roslib'
+
+pkgname='ros-melodic-roslib'
+pkgver='1.14.3'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-rospack
+ ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost)
+
+ros_depends=(ros-melodic-ros-environment
+ ros-melodic-rospack
+ ros-melodic-catkin)
+depends=(${ros_depends[@]}
+ python2-rospkg)
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/roslib/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros-release-release-melodic-roslib-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros-release/archive/release/melodic/roslib/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('ffea38338ce18f6e17824790aa5afbbe3b6af9f81dd81f889e5ac9347836754c')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}