summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-06-22 10:55:37 +0100
committerGonçalo Camelo Neves Pereira2018-06-22 10:55:37 +0100
commitfc72e74e3ebaa3ff569c0db687f72d3dcf35d8f0 (patch)
treeaab084b6535e429eb70d19ad96ff46f97d6aba37
downloadaur-fc72e74e3ebaa3ff569c0db687f72d3dcf35d8f0.tar.gz
Update
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD63
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2893c7d0e561
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ros-melodic-roslisp-repl
+ pkgdesc = ROS - This package provides a script that launches Emacs with Slime (the Superior Lisp Interaction Mode) ready for Lisp development and roslisp.
+ pkgver = 0.4.12
+ pkgrel = 1
+ url = http://www.ros.org/
+ arch = any
+ license = Public domain
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-slime-ros
+ depends = ros-melodic-slime-wrapper
+ depends = ros-melodic-roslisp
+ depends = ros-melodic-rosemacs
+ depends = sbcl
+ source = ros-melodic-roslisp-repl-0.4.12-0.tar.gz::https://github.com/code-iai-release/ros_emacs_utils-release/archive/release/melodic/roslisp_repl/0.4.12-0.tar.gz
+ sha256sums = 990a1af10fe48b76c89e5295d840a5db45f9b8f303ce0dc1d5dd91fa72a4f23f
+
+pkgname = ros-melodic-roslisp-repl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0b469a744c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - This package provides a script that launches Emacs with Slime (the Superior Lisp Interaction Mode) ready for Lisp development and roslisp."
+url='http://www.ros.org/'
+
+pkgname='ros-melodic-roslisp-repl'
+pkgver='0.4.12'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('Public domain')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-slime-ros
+ ros-melodic-slime-wrapper
+ ros-melodic-roslisp
+ ros-melodic-rosemacs)
+depends=(${ros_depends[@]}
+ sbcl)
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/roslisp_repl/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/code-iai-release/ros_emacs_utils-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_emacs_utils-release-release-melodic-roslisp_repl-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/code-iai-release/ros_emacs_utils-release/archive/release/melodic/roslisp_repl/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('990a1af10fe48b76c89e5295d840a5db45f9b8f303ce0dc1d5dd91fa72a4f23f')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}