summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2019-01-09 19:17:31 +0100
committerGonçalo Camelo Neves Pereira2019-01-09 19:17:31 +0100
commit3ef7549eb103a438e2f441a809dff11ac2a9789f (patch)
treef90af1c2294bf08780168adcb9a1d81b327ecc1f
parent23d698b63aa48be2df2e86792cf1bdd1a99171be (diff)
downloadaur-3ef7549eb103a438e2f441a809dff11ac2a9789f.tar.gz
New Version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD82
2 files changed, 45 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 048f6066aa88..8d6f2fd7e94c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,11 +8,11 @@ pkgbase = ros-melodic-rosmsg
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
+ depends = ros-melodic-genpy
depends = ros-melodic-rosbag
- depends = ros-melodic-genmsg
depends = ros-melodic-catkin
+ depends = ros-melodic-genmsg
depends = ros-melodic-roslib
- depends = ros-melodic-genpy
depends = python-rospkg
source = ros-melodic-rosmsg-1.14.3-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rosmsg/1.14.3-0.tar.gz
sha256sums = d6b76ae3f2df2b92e423f03b57ddd325f928e6d16b1fbcac2939fd173ce3195d
diff --git a/PKGBUILD b/PKGBUILD
index 281918f4205b..40a27b404eaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - rosmsg contains two command-line tools: rosmsg and rossrv."
url='http://ros.org/wiki/rosmsg'
@@ -10,55 +10,59 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-catkin
+)
-ros_depends=(ros-melodic-rosbag
- ros-melodic-genmsg
- ros-melodic-catkin
- ros-melodic-roslib
- ros-melodic-genpy)
-depends=(${ros_depends[@]}
- python-rospkg)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/rosmsg/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-genpy
+ ros-melodic-rosbag
+ ros-melodic-catkin
+ ros-melodic-genmsg
+ ros-melodic-roslib
+)
+
+depends=(
+ ${ros_depends[@]}
+ python-rospkg
+)
-# Tarball version (faster download)
_dir="ros_comm-release-release-melodic-rosmsg-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rosmsg/${pkgver}-${_pkgver_patch}.tar.gz")
sha256sums=('d6b76ae3f2df2b92e423f03b57ddd325f928e6d16b1fbcac2939fd173ce3195d')
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}