summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGPereira2018-02-24 12:24:05 +0000
committerGPereira2018-02-24 12:24:05 +0000
commit2b0954cb4add21281c789c6488567fec1c305a33 (patch)
treeaf5fe68c23a83e8ab74e939aa8782841459d2a05
downloadaur-2b0954cb4add21281c789c6488567fec1c305a33.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD62
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fe8e2de5327
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ros-melodic-rosout
+ pkgdesc = ROS - System-wide logging mechanism for messages sent to the /rosout topic.
+ pkgver = 1.13.6
+ pkgrel = 1
+ url = http://ros.org/wiki/rosout
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-rosgraph-msgs
+ makedepends = ros-melodic-roscpp
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-rosgraph-msgs
+ depends = ros-melodic-roscpp
+ source = ros-melodic-rosout-1.13.6-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rosout/1.13.6-0.tar.gz
+ sha256sums = bdd19aef4ddf58d6c2fe2f305bcae0e646132dc967b7c35e27c622876a61de6d
+
+pkgname = ros-melodic-rosout
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..353fb361bb6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - System-wide logging mechanism for messages sent to the /rosout topic."
+url='http://ros.org/wiki/rosout'
+
+pkgname='ros-melodic-rosout'
+pkgver='1.13.6'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-rosgraph-msgs
+ ros-melodic-roscpp
+ ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-rosgraph-msgs
+ ros-melodic-roscpp)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/rosout/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_comm-release-release-melodic-rosout-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rosout/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('bdd19aef4ddf58d6c2fe2f305bcae0e646132dc967b7c35e27c622876a61de6d')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}