summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 14:59:18 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 14:59:18 +0200
commit492bf72bf311938960762a61175d05a7643f9fd7 (patch)
treecdab4a93460151cbbe400a2fdf0085ee19269651
parent921ff5f080793984cb5e1ce8e79e43f76a1e5ce5 (diff)
downloadaur-492bf72bf311938960762a61175d05a7643f9fd7.tar.gz
Update!
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD107
2 files changed, 70 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e60c8cf3c9b9..4e9cfff7fc9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ros-melodic-rospy
pkgdesc = ROS - rospy is a pure Python client library for ROS.
- pkgver = 1.14.2
+ pkgver = 1.14.3
pkgrel = 1
url = http://ros.org/wiki/rospy
arch = any
@@ -8,17 +8,17 @@ pkgbase = ros-melodic-rospy
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
+ depends = ros-melodic-genpy
depends = ros-melodic-rosgraph
- depends = ros-melodic-std-msgs
+ depends = ros-melodic-roslib
depends = ros-melodic-rosgraph-msgs
depends = ros-melodic-roscpp
- depends = ros-melodic-roslib
- depends = ros-melodic-genpy
- depends = python2-rospkg
- depends = python2-numpy
- depends = python2-yaml
- source = ros-melodic-rospy-1.14.2-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rospy/1.14.2-0.tar.gz
- sha256sums = 7f96aaea87bde1a81feae10f58bc4b1bc318af56a0126e0d34e1b9ec1f9447e1
+ depends = ros-melodic-std-msgs
+ depends = python-yaml
+ depends = python-rospkg
+ depends = python-numpy
+ source = ros-melodic-rospy::git+https://github.com/ros-gbp/ros_comm-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-rospy
diff --git a/PKGBUILD b/PKGBUILD
index 5c0839a012e4..b9c962908fec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,67 +1,82 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - rospy is a pure Python client library for ROS."
url='http://ros.org/wiki/rospy'
pkgname='ros-melodic-rospy'
-pkgver='1.14.2'
+pkgver='1.14.3'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-catkin
+)
-ros_depends=(ros-melodic-rosgraph
- ros-melodic-std-msgs
- ros-melodic-rosgraph-msgs
- ros-melodic-roscpp
- ros-melodic-roslib
- ros-melodic-genpy)
-depends=(${ros_depends[@]}
- python2-rospkg
- python2-numpy
- python2-yaml)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/rospy/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-genpy
+ ros-melodic-rosgraph
+ ros-melodic-roslib
+ ros-melodic-rosgraph-msgs
+ ros-melodic-roscpp
+ ros-melodic-std-msgs
+)
-# Tarball version (faster download)
-_dir="ros_comm-release-release-melodic-rospy-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rospy/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('7f96aaea87bde1a81feae10f58bc4b1bc318af56a0126e0d34e1b9ec1f9447e1')
+depends=(
+ ${ros_depends[@]}
+ python-yaml
+ python-rospkg
+ python-numpy
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}