summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGPereira2018-02-24 12:25:39 +0000
committerGPereira2018-02-24 12:25:39 +0000
commitb31f958cf72d077e15583b3910f2d92c9163d005 (patch)
tree0d933bba26284f567ecca921d57883ed62c6f4a1
downloadaur-b31f958cf72d077e15583b3910f2d92c9163d005.tar.gz
Initial Commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD66
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3c5de31e646
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ros-melodic-rostest
+ pkgdesc = ROS - Integration test suite based on roslaunch that is compatible with xUnit frameworks.
+ pkgver = 1.13.6
+ pkgrel = 1
+ url = http://ros.org/wiki/rostest
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-rosunit
+ makedepends = boost
+ depends = ros-melodic-rosgraph
+ depends = ros-melodic-rospy
+ depends = ros-melodic-rosmaster
+ depends = ros-melodic-rosunit
+ depends = ros-melodic-roslaunch
+ depends = boost
+ source = ros-melodic-rostest-1.13.6-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rostest/1.13.6-0.tar.gz
+ sha256sums = 48219b617f7efeb9e9c860d2d8d42437bf16b3d953fbff163db40196b2cc0bdc
+
+pkgname = ros-melodic-rostest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f429f401e124
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Integration test suite based on roslaunch that is compatible with xUnit frameworks."
+url='http://ros.org/wiki/rostest'
+
+pkgname='ros-melodic-rostest'
+pkgver='1.13.6'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin
+ ros-melodic-rosunit)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost)
+
+ros_depends=(ros-melodic-rosgraph
+ ros-melodic-rospy
+ ros-melodic-rosmaster
+ ros-melodic-rosunit
+ ros-melodic-roslaunch)
+depends=(${ros_depends[@]}
+ boost)
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/rostest/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_comm-release-release-melodic-rostest-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rostest/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('48219b617f7efeb9e9c860d2d8d42437bf16b3d953fbff163db40196b2cc0bdc')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}