summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:33:55 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:33:55 +0200
commitdb074168665a0c9a025ba338817a5a24b72a57ba (patch)
treeab08682869f9c3df165baf00770223b12c0deceb
parentc5d1b0d0239787a6791dd3549a8ac84b2b7db968 (diff)
downloadaur-db074168665a0c9a025ba338817a5a24b72a57ba.tar.gz
Update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD103
2 files changed, 48 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d99d47fc43d..a7c30c79526e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,14 +10,14 @@ pkgbase = ros-melodic-rostest
makedepends = ros-melodic-catkin
makedepends = ros-melodic-rosunit
makedepends = boost
- depends = ros-melodic-rosmaster
depends = ros-melodic-rosgraph
depends = ros-melodic-rospy
- depends = ros-melodic-roslaunch
+ depends = ros-melodic-rosmaster
depends = ros-melodic-rosunit
+ depends = ros-melodic-roslaunch
depends = boost
- source = ros-melodic-rostest::git+https://github.com/ros-gbp/ros_comm-release.git
- sha256sums = SKIP
+ source = ros-melodic-rostest-1.14.3-0.tar.gz::https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rostest/1.14.3-0.tar.gz
+ sha256sums = 90e7b4ba3167ae06f5ad213c193b0c5ab7888b4abd75542a3d7c02592ef9c707
pkgname = ros-melodic-rostest
diff --git a/PKGBUILD b/PKGBUILD
index 6ac3c742fc7d..a3d4ad80538e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - Integration test suite based on roslaunch that is compatible with xUnit frameworks."
url='http://ros.org/wiki/rostest'
@@ -10,72 +10,57 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-catkin
- ros-melodic-rosunit
-)
+ros_makedepends=(ros-melodic-catkin
+ ros-melodic-rosunit)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost)
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
- boost
-)
+ros_depends=(ros-melodic-rosgraph
+ ros-melodic-rospy
+ ros-melodic-rosmaster
+ ros-melodic-rosunit
+ ros-melodic-roslaunch)
+depends=(${ros_depends[@]}
+ boost)
-ros_depends=(
- ros-melodic-rosmaster
- ros-melodic-rosgraph
- ros-melodic-rospy
- ros-melodic-roslaunch
- ros-melodic-rosunit
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/rostest/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
- boost
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="ros_comm-release-release-melodic-rostest-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/melodic/rostest/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('90e7b4ba3167ae06f5ad213c193b0c5ab7888b4abd75542a3d7c02592ef9c707')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}