summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:34:00 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:34:00 +0200
commit0bcfbbe56a5d9a094bab1e1c95613940d9baaa54 (patch)
tree247da475d8aa8aee5fde9342575d0c51ae1890da
parent81662c264dd8fe252a48e856b6ab5e3399ed0f21 (diff)
downloadaur-0bcfbbe56a5d9a094bab1e1c95613940d9baaa54.tar.gz
Update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD101
2 files changed, 45 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46d85013d5e3..793e8e9f3b22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,8 +12,8 @@ pkgbase = ros-melodic-rostime
makedepends = boost
depends = ros-melodic-cpp-common
depends = boost
- source = ros-melodic-rostime::git+https://github.com/ros-gbp/roscpp_core-release.git
- sha256sums = SKIP
+ source = ros-melodic-rostime-0.6.11-0.tar.gz::https://github.com/ros-gbp/roscpp_core-release/archive/release/melodic/rostime/0.6.11-0.tar.gz
+ sha256sums = 62c1a91cc0cce69c4d4e8800ab348f8b64e7252482f6196cfcb5a2a22b27308f
pkgname = ros-melodic-rostime
diff --git a/PKGBUILD b/PKGBUILD
index 09d1f21cc44f..996cba084622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - Time and Duration implementations for C++ libraries, including roscpp."
url='http://ros.org/wiki/rostime'
@@ -10,68 +10,53 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-cpp-common
- ros-melodic-catkin
-)
+ros_makedepends=(ros-melodic-cpp-common
+ ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost)
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
- boost
-)
+ros_depends=(ros-melodic-cpp-common)
+depends=(${ros_depends[@]}
+ boost)
-ros_depends=(
- ros-melodic-cpp-common
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/rostime/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/roscpp_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
- boost
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/roscpp_core-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="roscpp_core-release-release-melodic-rostime-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/roscpp_core-release/archive/release/melodic/rostime/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('62c1a91cc0cce69c4d4e8800ab348f8b64e7252482f6196cfcb5a2a22b27308f')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}