summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-02-16 00:24:25 -0500
committeracxz2020-02-16 00:24:25 -0500
commitdaeb6384026c72a4244e0ce46d6e7d6a2966a487 (patch)
tree5100cec67166374436bede47e1c2dc9d179e7161
downloadaur-daeb6384026c72a4244e0ce46d6e7d6a2966a487.tar.gz
create ros-melodic-rotors-description package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD59
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7f22883dc23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ros-melodic-rotors-description
+ pkgdesc = ROS - The rotors_description package provides URDF modles of the AscTec multicopters.
+ pkgver = 2.2.3
+ pkgrel = 1
+ url = https://wiki.ros.org/rotors_description
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
+ license = ASL 2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ source = ros-melodic-rotors-description-2.2.3.tar.gz::https://github.com/ethz-asl/rotors_simulator/archive/2.2.3.tar.gz
+ sha256sums = 46e6be40ebd08ba41a4a532c1774228d240d11aa39ad82f9ab50e445dc4a6f20
+
+pkgname = ros-melodic-rotors-description
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b42ca57a0170
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
+pkgdesc="ROS - The rotors_description package provides URDF modles of the AscTec
+multicopters."
+url='https://wiki.ros.org/rotors_description'
+
+pkgname='ros-melodic-rotors-description'
+pkgver='2.2.3'
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
+pkgrel=1
+license=('ASL 2.0')
+
+ros_makedepends=(
+ ros-melodic-catkin
+)
+
+makedepends=(
+ cmake
+ ros-build-tools
+ ${ros_makedepends[@]}
+)
+
+ros_depends=(
+)
+
+depends=(
+ ${ros_depends[@]}
+)
+
+_dir="rotors_simulator-${pkgver}/rotors_description"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ethz-asl/rotors_simulator/archive/${pkgver}.tar.gz")
+sha256sums=('46e6be40ebd08ba41a4a532c1774228d240d11aa39ad82f9ab50e445dc4a6f20')
+
+build() {
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}