summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:34:49 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:34:49 +0200
commitd804e251ec5229fc4e2e99e806b58b96e38d0ffb (patch)
tree9d999e969802271b42e54a28e972380cec3cf0cb
parent9504c9bc4b6ec1b7a816b20f50909bc1568b8ed1 (diff)
downloadaur-d804e251ec5229fc4e2e99e806b58b96e38d0ffb.tar.gz
Update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD101
2 files changed, 47 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 522f1e05b6a2..4942a2115f5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,14 +9,14 @@ pkgbase = ros-melodic-rqt-dep
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
depends = ros-melodic-rqt-gui-py
- depends = ros-melodic-qt-gui-py-common
- depends = ros-melodic-python-qt-binding
depends = ros-melodic-rqt-graph
depends = ros-melodic-qt-dotgraph
+ depends = ros-melodic-qt-gui-py-common
depends = ros-melodic-qt-gui
+ depends = ros-melodic-python-qt-binding
depends = python-rospkg
- source = ros-melodic-rqt-dep::git+https://github.com/ros-gbp/rqt_dep-release.git
- sha256sums = SKIP
+ source = ros-melodic-rqt-dep-0.4.9-0.tar.gz::https://github.com/ros-gbp/rqt_dep-release/archive/release/melodic/rqt_dep/0.4.9-0.tar.gz
+ sha256sums = 7fa60310716f75eb444c3f45578111826f1e2bcdc092a1a5b530bfef04b8fb7a
pkgname = ros-melodic-rqt-dep
diff --git a/PKGBUILD b/PKGBUILD
index a5f49cbec3f4..cfd0738d11ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - rqt_dep provides a GUI plugin for visualizing the ROS dependency graph."
url='http://wiki.ros.org/rqt_dep'
@@ -10,71 +10,56 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-catkin
-)
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-rqt-gui-py
+ ros-melodic-rqt-graph
+ ros-melodic-qt-dotgraph
+ ros-melodic-qt-gui-py-common
+ ros-melodic-qt-gui
+ ros-melodic-python-qt-binding)
+depends=(${ros_depends[@]}
+ python-rospkg)
-ros_depends=(
- ros-melodic-rqt-gui-py
- ros-melodic-qt-gui-py-common
- ros-melodic-python-qt-binding
- ros-melodic-rqt-graph
- ros-melodic-qt-dotgraph
- ros-melodic-qt-gui
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/rqt_dep/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_dep-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
- python-rospkg
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_dep-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="rqt_dep-release-release-melodic-rqt_dep-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_dep-release/archive/release/melodic/rqt_dep/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('7fa60310716f75eb444c3f45578111826f1e2bcdc092a1a5b530bfef04b8fb7a')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}