summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2019-01-09 19:35:31 +0100
committerGonçalo Camelo Neves Pereira2019-01-09 19:35:31 +0100
commitb5829d7f99dcfc20db4877438838a4d286dd389a (patch)
tree3bb4ba3d04cd703a5415d07ad57302d212a5e7c7
parent4593917fa96533dd7c090dcadce6f2e70f0c269c (diff)
downloadaur-b5829d7f99dcfc20db4877438838a4d286dd389a.tar.gz
New Version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD92
2 files changed, 54 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a471954b863..ff32cadd1182 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,17 +8,17 @@ pkgbase = ros-melodic-rqt-pose-view
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
- depends = ros-melodic-rostopic
- depends = ros-melodic-tf
- depends = ros-melodic-gl-dependency
depends = ros-melodic-rqt-py-common
- depends = ros-melodic-geometry-msgs
depends = ros-melodic-rqt-gui-py
- depends = ros-melodic-rqt-gui
+ depends = ros-melodic-gl-dependency
+ depends = ros-melodic-tf
+ depends = ros-melodic-rostopic
depends = ros-melodic-python-qt-binding
+ depends = ros-melodic-rqt-gui
depends = ros-melodic-rospy
- depends = python-rospkg
+ depends = ros-melodic-geometry-msgs
depends = python-opengl
+ depends = python-rospkg
source = ros-melodic-rqt-pose-view-0.5.8-0.tar.gz::https://github.com/ros-gbp/rqt_pose_view-release/archive/release/melodic/rqt_pose_view/0.5.8-0.tar.gz
sha256sums = 00e9962e4a7132dcb9082692fb49563d309b9e446b5eb17e65354dd7e1e24e4d
diff --git a/PKGBUILD b/PKGBUILD
index b4450bdfde59..09dbde40fdf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - rqt_pose_view provides a GUI plugin for visualizing 3D poses."
url='http://wiki.ros.org/rqt_pose_view'
@@ -10,60 +10,64 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-catkin
+)
-ros_depends=(ros-melodic-rostopic
- ros-melodic-tf
- ros-melodic-gl-dependency
- ros-melodic-rqt-py-common
- ros-melodic-geometry-msgs
- ros-melodic-rqt-gui-py
- ros-melodic-rqt-gui
- ros-melodic-python-qt-binding
- ros-melodic-rospy)
-depends=(${ros_depends[@]}
- python-rospkg
- python-opengl)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/rqt_pose_view/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_pose_view-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-rqt-py-common
+ ros-melodic-rqt-gui-py
+ ros-melodic-gl-dependency
+ ros-melodic-tf
+ ros-melodic-rostopic
+ ros-melodic-python-qt-binding
+ ros-melodic-rqt-gui
+ ros-melodic-rospy
+ ros-melodic-geometry-msgs
+)
+
+depends=(
+ ${ros_depends[@]}
+ python-opengl
+ python-rospkg
+)
-# Tarball version (faster download)
_dir="rqt_pose_view-release-release-melodic-rqt_pose_view-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_pose_view-release/archive/release/melodic/rqt_pose_view/${pkgver}-${_pkgver_patch}.tar.gz")
sha256sums=('00e9962e4a7132dcb9082692fb49563d309b9e446b5eb17e65354dd7e1e24e4d')
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}