summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 15:01:43 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 15:01:43 +0200
commit7ab4d01d4646154a315ba636d13a9825b2afb5b1 (patch)
treee2c3c730f57f2c5f3ffdada09764cd36ed07f520
parentbcc4e29be490fe73540eca2b7b9c5c9dd854c4b8 (diff)
downloadaur-7ab4d01d4646154a315ba636d13a9825b2afb5b1.tar.gz
Update!
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD105
2 files changed, 69 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a099a11a19dd..ea0643b80cdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,17 +8,17 @@ pkgbase = ros-melodic-rqt-robot-plugins
makedepends = cmake
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
- depends = ros-melodic-rqt-robot-dashboard
- depends = ros-melodic-rqt-nav-view
- depends = ros-melodic-rqt-tf-tree
- depends = ros-melodic-rqt-rviz
- depends = ros-melodic-rqt-runtime-monitor
- depends = ros-melodic-rqt-robot-steering
+ depends = ros-melodic-rqt-robot-monitor
depends = ros-melodic-rqt-moveit
+ depends = ros-melodic-rqt-rviz
depends = ros-melodic-rqt-pose-view
- depends = ros-melodic-rqt-robot-monitor
- source = ros-melodic-rqt-robot-plugins-0.5.7-0.tar.gz::https://github.com/ros-gbp/rqt_robot_plugins-release/archive/release/melodic/rqt_robot_plugins/0.5.7-0.tar.gz
- sha256sums = 2fa30a70d1eed9ff4724c1b9d1ef8303066b373bae9abcbf2b8a715a89e515ba
+ depends = ros-melodic-rqt-nav-view
+ depends = ros-melodic-rqt-robot-steering
+ depends = ros-melodic-rqt-runtime-monitor
+ depends = ros-melodic-rqt-robot-dashboard
+ depends = ros-melodic-rqt-tf-tree
+ source = ros-melodic-rqt-robot-plugins::git+https://github.com/ros-gbp/rqt_robot_plugins-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-rqt-robot-plugins
diff --git a/PKGBUILD b/PKGBUILD
index 72c43444d16b..b46b208c2d54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - Metapackage of rqt plugins that are particularly used with robots during its operation."
url='http://ros.org/wiki/rqt_robot_plugins'
@@ -10,58 +10,73 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-catkin
+)
-ros_depends=(ros-melodic-rqt-robot-dashboard
- ros-melodic-rqt-nav-view
- ros-melodic-rqt-tf-tree
- ros-melodic-rqt-rviz
- ros-melodic-rqt-runtime-monitor
- ros-melodic-rqt-robot-steering
- ros-melodic-rqt-moveit
- ros-melodic-rqt-pose-view
- ros-melodic-rqt-robot-monitor)
-depends=(${ros_depends[@]})
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/rqt_robot_plugins/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_robot_plugins-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-rqt-robot-monitor
+ ros-melodic-rqt-moveit
+ ros-melodic-rqt-rviz
+ ros-melodic-rqt-pose-view
+ ros-melodic-rqt-nav-view
+ ros-melodic-rqt-robot-steering
+ ros-melodic-rqt-runtime-monitor
+ ros-melodic-rqt-robot-dashboard
+ ros-melodic-rqt-tf-tree
+)
-# Tarball version (faster download)
-_dir="rqt_robot_plugins-release-release-melodic-rqt_robot_plugins-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_robot_plugins-release/archive/release/melodic/rqt_robot_plugins/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('2fa30a70d1eed9ff4724c1b9d1ef8303066b373bae9abcbf2b8a715a89e515ba')
+depends=(
+ ${ros_depends[@]}
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_robot_plugins-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}