summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:37:05 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:37:05 +0200
commitdfc6fd68843c501b7a9e3dcd5aedffc3477194c9 (patch)
tree26388ca97bf0be1feb7eaa49edf1c75f80d3bd02
parentb36796d5f39b8552db00a38f117594c28193d4f2 (diff)
downloadaur-dfc6fd68843c501b7a9e3dcd5aedffc3477194c9.tar.gz
Update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD103
2 files changed, 47 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab8e317aa55f..fef7b5cdfac5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,12 +9,12 @@ pkgbase = ros-melodic-rqt-top
makedepends = ros-build-tools
makedepends = ros-melodic-catkin
depends = ros-melodic-rqt-gui
- depends = ros-melodic-python-qt-binding
depends = ros-melodic-rqt-gui-py
+ depends = ros-melodic-python-qt-binding
depends = ros-melodic-rospy
depends = python-psutil
- source = ros-melodic-rqt-top::git+https://github.com/ros-gbp/rqt_top-release.git
- sha256sums = SKIP
+ source = ros-melodic-rqt-top-0.4.8-0.tar.gz::https://github.com/ros-gbp/rqt_top-release/archive/release/melodic/rqt_top/0.4.8-0.tar.gz
+ sha256sums = 06a64dcb66e010ec7fa6e474dcd0b50efac71516ecb6a247c38652d309ee7c8a
pkgname = ros-melodic-rqt-top
diff --git a/PKGBUILD b/PKGBUILD
index 8516d1f379c1..fd5fefede1a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - RQT plugin for monitoring ROS processes."
url='http://wiki.ros.org/rqt_top'
@@ -10,69 +10,54 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-catkin
-)
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-rqt-gui
+ ros-melodic-rqt-gui-py
+ ros-melodic-python-qt-binding
+ ros-melodic-rospy)
+depends=(${ros_depends[@]}
+ python-psutil)
-ros_depends=(
- ros-melodic-rqt-gui
- ros-melodic-python-qt-binding
- ros-melodic-rqt-gui-py
- ros-melodic-rospy
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/rqt_top/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_top-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
- python-psutil
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_top-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="rqt_top-release-release-melodic-rqt_top-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_top-release/archive/release/melodic/rqt_top/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('06a64dcb66e010ec7fa6e474dcd0b50efac71516ecb6a247c38652d309ee7c8a')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}