summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-06-27 11:49:27 -0400
committeracxz2019-06-27 11:49:27 -0400
commitf7f0103bdaa40c7da5291558c45b4e7a2905e84d (patch)
tree5905cd3616688851acb0d0ded67469cdab12feef
parent75ce05c6e98993eb63fc2326f6844dd929c52317 (diff)
downloadaur-f7f0103bdaa40c7da5291558c45b4e7a2905e84d.tar.gz
build fix for missing env variable
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 368cee2fa551..3f2a6008a224 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-rviz
pkgdesc = ROS - 3D visualization tool for ROS.
pkgver = 1.13.3
- pkgrel = 1
+ pkgrel = 2
url = http://ros.org/wiki/rviz
arch = any
license = BSD, Creative Commons
diff --git a/PKGBUILD b/PKGBUILD
index 962465c45d46..a30c5543673c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ url='http://ros.org/wiki/rviz'
pkgname='ros-melodic-rviz'
pkgver='1.13.3'
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD, Creative Commons')
ros_makedepends=(
@@ -117,7 +117,16 @@ build() {
-DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
-DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
+
+ make || {
+ # Replace $$[QT_INSTALL_LIBS] with hardcoded /usr/lib/ for proper linking
+ # Fix courtesy of astier:
+ # https://aur.archlinux.org/packages/ros-melodic-rviz/#comment-698298
+ # Relevant upstream issue:
+ # https://github.com/ros-visualization/rviz/issues/1382
+ sed -i 's/$$\[QT_INSTALL_LIBS\]/\/usr\/lib/' ${srcdir}/build/devel/bin/sip/rviz_sip/Makefile
make
+ }
}
package() {