summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormajor2020-01-09 02:45:19 +0000
committermajor2020-01-09 02:45:19 +0000
commitc92aae9f85945a36b20121f8c76928d0714850e0 (patch)
treec64f0aa793a5199db947b6e7721e4832f527f29b
downloadaur-c92aae9f85945a36b20121f8c76928d0714850e0.tar.gz
initial commit with adjusted kinetic package (changes python2 to python3, kinetic to melodic)
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD59
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e5ffccec383
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ros-melodic-sbpl-lattice-planner
+ pkgdesc = ROS - SBPL Lattice Planner provides a path planning algorithm for ROS
+ pkgver = 0.3.2
+ pkgrel = 1
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = pkg-config
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-roscpp
+ depends = ros-melodic-costmap-2d
+ depends = ros-melodic-nav-core
+ depends = ros-melodic-pluginlib
+ depends = ros-melodic-geometry-msgs
+ depends = ros-melodic-nav-msgs
+ depends = ros-melodic-message-generation
+ depends = python-rospkg
+ options = !makeflags
+ source = ros-melodic-sbpl-lattice-planner::git+https://github.com/ros-planning/navigation_experimental.git
+ sha256sums = SKIP
+
+pkgname = ros-melodic-sbpl-lattice-planner
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2854a6a93382
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - SBPL Lattice Planner provides a path planning algorithm for ROS"
+
+pkgname='ros-melodic-sbpl-lattice-planner'
+pkgver='0.3.2'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools' 'pkg-config' ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-roscpp
+ros-melodic-costmap-2d
+ros-melodic-nav-core
+ros-melodic-pluginlib
+ros-melodic-geometry-msgs
+ros-melodic-nav-msgs
+ros-melodic-message-generation)
+depends=(${ros_depends[@]}
+ python-rospkg)
+
+# Git version (e.g. for debugging)
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-planning/navigation_experimental.git")
+sha256sums=('SKIP')
+options=('!makeflags')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${pkgname}/sbpl_lattice_planner \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.8 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.8.so \
+ -DPYTHON_BASENAME=-python3.8 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}