summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Henrik Bruhn2020-01-16 20:46:07 +0100
committerJan-Henrik Bruhn2020-01-16 20:46:07 +0100
commitfbb3be3b2dff63c79a24cfe9b688d7aed888fb42 (patch)
treee1eefebc63c62cd831be0604a59161fd2b647d45
downloadaur-fbb3be3b2dff63c79a24cfe9b688d7aed888fb42.tar.gz
Initial commit of ros melodic serial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD56
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1fd37137f73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ros-melodic-serial
+ pkgdesc = ROS - Serial is a cross-platform, simple to use library for using serial ports on computers.
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = h
+ arch = any
+ license = MIT
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ source = ros-melodic-serial-1.2.1.tar.gz::https://github.com/wjwwood/serial-release/archive/release/melodic/serial/1.2.1.tar.gz
+ sha256sums = 3591de6b9035a647e0c3050109fb7d342681742e617bbf0e8f3d828e21b84c0f
+
+pkgname = ros-melodic-serial
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fe103129550
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Script generated with create_pkgbuild.py
+ # For more information: https://github.com/ros-melodic-arch/ros-build-tools-py3
+ pkgdesc="ROS - Serial is a cross-platform, simple to use library for using serial ports on computers."
+ url='h'
+
+ pkgname='ros-melodic-serial'
+ pkgver='1.2.1'
+ arch=('any')
+ pkgrel=1
+ license=('MIT')
+
+ ros_makedepends=(ros-melodic-catkin)
+ makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ )
+
+ ros_depends=()
+ depends=(${ros_depends[@]}
+ )
+
+ # Tarball version (faster download)
+ _dir="serial-release-release-melodic-serial"
+ source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/wjwwood/serial-release/archive/release/melodic/serial/${pkgver}.tar.gz")
+ sha256sums=('3591de6b9035a647e0c3050109fb7d342681742e617bbf0e8f3d828e21b84c0f')
+
+ build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_ENABLE_TESTING=0 \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+ }
+
+ package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+ }
+ \ No newline at end of file