summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZHOU Yue2018-09-27 17:37:53 +0800
committerZHOU Yue2018-09-27 17:37:53 +0800
commit48294d09ce017c6e34ad7daff7251318694b01ce (patch)
tree5e96f3a9a6ebdbb2e7a3e0d25c539081ec5dcc74
parent3e0c45aa50e5a05172075e0229fc0b92b0f09ebb (diff)
downloadaur-48294d09ce017c6e34ad7daff7251318694b01ce.tar.gz
change to use python3.7
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fffd208ef80..90cc90566644 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-socketcan-bridge
pkgdesc = Conversion nodes for messages from SocketCAN to a ROS Topic and vice versa.
pkgver = 0.8.0
- pkgrel = 2
+ pkgrel = 3
url = http://wiki.ros.org/socketcan_bridge?distro=melodic
arch = any
license = LGPL3
diff --git a/PKGBUILD b/PKGBUILD
index 733a427304a6..81104643133d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc='Conversion nodes for messages from SocketCAN to a ROS Topic and vice ve
url="http://wiki.ros.org/${_pkgname}?distro=melodic"
pkgver=0.8.0
-pkgrel=2
+pkgrel=3
arch=('any')
license=('LGPL3')
@@ -32,24 +32,24 @@ build() {
source /usr/share/ros-build-tools/clear-ros-env.sh
[ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-# # Fix Python2/Python3 conflicts
-# /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
-
# Create build directory
- [ -d ${srcdir}/build ] || mkdir -p ${srcdir}/build
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
# Build project
cmake ${srcdir}/${_dir}/${_pkgname} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DCATKIN_ENABLE_TESTING=OFF \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
-# -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-# -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-# -DPYTHON_BASENAME=-python2.7 \
-# -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
make
}