summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-02-08 17:26:43 -0500
committeracxz2020-02-08 17:26:43 -0500
commit2bd10980fe8d52d4e7dd079ad36a13bc92ff8cd9 (patch)
tree308eafc792c9806073169d562c222b0ba8ad976f
downloadaur-2bd10980fe8d52d4e7dd079ad36a13bc92ff8cd9.tar.gz
create ros-melodic-summit-xl-navigation package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD67
2 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ade8351f80b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ros-melodic-summit-xl-navigation
+ pkgdesc = ROS - Navigation launch and config files for Summit XL robot.
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = https://wiki.ros.org/summit_xl_navigation
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-teb-local-planner
+ makedepends = ros-melodic-costmap-prohibition-layer
+ makedepends = ros-melodic-move-base
+ depends = ros-melodic-teb-local-planner
+ depends = ros-melodic-costmap-prohibition-layer
+ depends = ros-melodic-move-base
+ source = ros-melodic-summit-xl-navigation-1.1.3.tar.gz::https://github.com/RobotnikAutomation/summit_xl_common/archive/kinetic-1.1.3.tar.gz
+ sha256sums = 8979bdda706b4cfd155df3f22aeecf56869e227113a9947f99f1dfee658d08fe
+
+pkgname = ros-melodic-summit-xl-navigation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2aacb75d0b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
+pkgdesc="ROS - Navigation launch and config files for Summit XL robot."
+url='https://wiki.ros.org/summit_xl_navigation'
+
+pkgname='ros-melodic-summit-xl-navigation'
+pkgver='1.1.3'
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(
+ ros-melodic-catkin
+ ros-melodic-teb-local-planner
+ ros-melodic-costmap-prohibition-layer
+ ros-melodic-move-base
+)
+
+makedepends=(
+ cmake
+ ros-build-tools
+ ${ros_makedepends[@]}
+)
+
+ros_depends=(
+ ros-melodic-teb-local-planner
+ ros-melodic-costmap-prohibition-layer
+ ros-melodic-move-base
+)
+
+depends=(
+ ${ros_depends[@]}
+)
+
+_dir="summit_xl_common-kinetic-${pkgver}/summit_xl_navigation"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/RobotnikAutomation/summit_xl_common/archive/kinetic-${pkgver}.tar.gz")
+sha256sums=('8979bdda706b4cfd155df3f22aeecf56869e227113a9947f99f1dfee658d08fe')
+
+build() {
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}