summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:39:20 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:39:20 +0200
commit3a0c3ff17406acf5c8acec96bb0ec65d218ee8a1 (patch)
tree1f84902bab4310881e1653abf19bf0332b28b442
parent5edf74ee05aa34138aa0f05d949c87b15f4357e8 (diff)
downloadaur-3a0c3ff17406acf5c8acec96bb0ec65d218ee8a1.tar.gz
Update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD105
2 files changed, 46 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6eef96d4b410..fb66f8d27c8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,13 +7,13 @@ pkgbase = ros-melodic-tf2-py
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-catkin
makedepends = ros-melodic-tf2
+ makedepends = ros-melodic-catkin
makedepends = ros-melodic-rospy
depends = ros-melodic-tf2
depends = ros-melodic-rospy
- source = ros-melodic-tf2-py::git+https://github.com/ros-gbp/geometry2-release.git
- sha256sums = SKIP
+ source = ros-melodic-tf2-py-0.6.3-0.tar.gz::https://github.com/ros-gbp/geometry2-release/archive/release/melodic/tf2_py/0.6.3-0.tar.gz
+ sha256sums = 8c5739e5bc4494db19282193409ee9a1a73a3a2c4a67bc8785e7c2d79f3468f4
pkgname = ros-melodic-tf2-py
diff --git a/PKGBUILD b/PKGBUILD
index 4a04e0599059..b12bc751cf0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - The tf2_py package."
url='http://ros.org/wiki/tf2_py'
@@ -10,72 +10,53 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-catkin
- ros-melodic-tf2
- ros-melodic-rospy
-)
+ros_makedepends=(ros-melodic-tf2
+ ros-melodic-catkin
+ ros-melodic-rospy)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-tf2
+ ros-melodic-rospy)
+depends=(${ros_depends[@]})
-ros_depends=(
- ros-melodic-tf2
- ros-melodic-rospy
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/tf2_py/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
- prepare() {
- # Python3.7 compatibility
- sed -i -e "/char \* data/d" -e "/data =/i\ \ const char * data;" -e "/PyString_AsStringAndSize/i\ \ char * data;" ${srcdir}/${_dir}/src/python_compat.h
-}
-}
+# Tarball version (faster download)
+_dir="geometry2-release-release-melodic-tf2_py-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry2-release/archive/release/melodic/tf2_py/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('8c5739e5bc4494db19282193409ee9a1a73a3a2c4a67bc8785e7c2d79f3468f4')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}