summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2019-01-09 19:22:01 +0100
committerGonçalo Camelo Neves Pereira2019-01-09 19:22:01 +0100
commitd94b5b4a80b06b42ed9c53cc9a05e9cf7c25b28b (patch)
treef43bb1471bcb6bfcd4a72722f18aa6623fba1dc5
parent3ec162acb33b54b0deb18af3ccc7ce6e17936b49 (diff)
downloadaur-d94b5b4a80b06b42ed9c53cc9a05e9cf7c25b28b.tar.gz
New Version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD98
2 files changed, 58 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72990a815046..b75045a77d34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,21 +7,21 @@ pkgbase = ros-melodic-turtle-tf2
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-std-msgs
- makedepends = ros-melodic-roscpp
makedepends = ros-melodic-turtlesim
- makedepends = ros-melodic-tf2-ros
- makedepends = ros-melodic-geometry-msgs
makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-std-msgs
+ makedepends = ros-melodic-tf2-ros
+ makedepends = ros-melodic-roscpp
makedepends = ros-melodic-tf2
makedepends = ros-melodic-rospy
- depends = ros-melodic-std-msgs
- depends = ros-melodic-roscpp
+ makedepends = ros-melodic-geometry-msgs
depends = ros-melodic-turtlesim
+ depends = ros-melodic-std-msgs
depends = ros-melodic-tf2-ros
- depends = ros-melodic-geometry-msgs
+ depends = ros-melodic-roscpp
depends = ros-melodic-tf2
depends = ros-melodic-rospy
+ depends = ros-melodic-geometry-msgs
source = ros-melodic-turtle-tf2-0.2.2-0.tar.gz::https://github.com/ros-gbp/geometry_tutorials-release/archive/release/melodic/turtle_tf2/0.2.2-0.tar.gz
sha256sums = 898be65b26bacc4c8ec117c9696b0506f18c33cce83c507442c3b4b239c64ada
diff --git a/PKGBUILD b/PKGBUILD
index f2b4a1013bee..af27dfaf06dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - turtle_tf2 demonstrates how to write a tf2 broadcaster and listener with the turtlesim."
url='http://www.ros.org/'
@@ -10,63 +10,67 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-std-msgs
- ros-melodic-roscpp
- ros-melodic-turtlesim
- ros-melodic-tf2-ros
- ros-melodic-geometry-msgs
- ros-melodic-catkin
- ros-melodic-tf2
- ros-melodic-rospy)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-turtlesim
+ ros-melodic-catkin
+ ros-melodic-std-msgs
+ ros-melodic-tf2-ros
+ ros-melodic-roscpp
+ ros-melodic-tf2
+ ros-melodic-rospy
+ ros-melodic-geometry-msgs
+)
-ros_depends=(ros-melodic-std-msgs
- ros-melodic-roscpp
- ros-melodic-turtlesim
- ros-melodic-tf2-ros
- ros-melodic-geometry-msgs
- ros-melodic-tf2
- ros-melodic-rospy)
-depends=(${ros_depends[@]})
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/turtle_tf2/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry_tutorials-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-turtlesim
+ ros-melodic-std-msgs
+ ros-melodic-tf2-ros
+ ros-melodic-roscpp
+ ros-melodic-tf2
+ ros-melodic-rospy
+ ros-melodic-geometry-msgs
+)
+
+depends=(
+ ${ros_depends[@]}
+)
-# Tarball version (faster download)
_dir="geometry_tutorials-release-release-melodic-turtle_tf2-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry_tutorials-release/archive/release/melodic/turtle_tf2/${pkgver}-${_pkgver_patch}.tar.gz")
sha256sums=('898be65b26bacc4c8ec117c9696b0506f18c33cce83c507442c3b4b239c64ada')
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}