summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-09-21 17:42:04 -0400
committeracxz2019-09-21 17:42:04 -0400
commit0d0b1a7d1f58076e1f49064465dee79f81ac5644 (patch)
tree5135be4fc2d689fbb1a28e709e54a16d1dcf44f7
downloadaur-0d0b1a7d1f58076e1f49064465dee79f81ac5644.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD69
2 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..091b84bc72d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ros-melodic-turtlebot3-fake
+ pkgdesc = ROS - Package for TurtleBot3 fake node. With this package, simple tests can be done without a robot. You can do simple tests using this package on rviz without real robots.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://wiki.ros.org/turtlebot3_fake
+ arch = any
+ license = Apache-2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = ros-melodic-roscpp
+ depends = ros-melodic-std-msgs
+ depends = ros-melodic-sensor-msgs
+ depends = ros-melodic-geometry-msgs
+ depends = ros-melodic-nav-msgs
+ depends = ros-melodic-tf
+ depends = ros-melodic-turtlebot3-msgs
+ depends = ros-melodic-robot-state-publisher
+ source = ros-melodic-turtlebot3-fake-1.2.0.tar.gz::https://github.com/ROBOTIS-GIT/turtlebot3_simulations/archive/1.2.0.tar.gz
+ sha256sums = 6fbb4cf74b9777c3be3a751dd8d638df2570dd4478681b5eadf51dee32f57c5b
+
+pkgname = ros-melodic-turtlebot3-fake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9239a5449588
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+pkgdesc="ROS - Package for TurtleBot3 fake node. With this package, simple tests
+can be done without a robot. You can do simple tests using this package on rviz
+without real robots."
+url='https://wiki.ros.org/turtlebot3_fake'
+
+pkgname='ros-melodic-turtlebot3-fake'
+pkgver='1.2.0'
+arch=('any')
+pkgrel=1
+license=('Apache-2.0')
+
+ros_makedepends=(
+ ros-melodic-catkin
+)
+
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
+
+ros_depends=(
+ ros-melodic-roscpp
+ ros-melodic-std-msgs
+ ros-melodic-sensor-msgs
+ ros-melodic-geometry-msgs
+ ros-melodic-nav-msgs
+ ros-melodic-tf
+ ros-melodic-turtlebot3-msgs
+ ros-melodic-robot-state-publisher
+)
+
+depends=(
+ ${ros_depends[@]}
+)
+
+_dir="turtlebot3_simulations-${pkgver}/turtlebot3_fake"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ROBOTIS-GIT/turtlebot3_simulations/archive/${pkgver}.tar.gz")
+sha256sums=('6fbb4cf74b9777c3be3a751dd8d638df2570dd4478681b5eadf51dee32f57c5b')
+
+build() {
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}