summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-11-01 02:00:01 -0400
committeracxz2019-11-01 02:00:01 -0400
commit15c637b8a02b4a7d6da327702aca0b44f97bcdac (patch)
treef9ab8421dd8a8fd11d8f46e6b629294805fedfef
downloadaur-15c637b8a02b4a7d6da327702aca0b44f97bcdac.tar.gz
create package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD67
2 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8bf4479a831c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ros-melodic-turtlebot3-gazebo
+ pkgdesc = ROS - Gazebo simulation package for the TurtleBot3
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://wiki.ros.org/turtlebot3_gazebo
+ arch = any
+ license = Apache-2.0
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-catkin
+ depends = gazebo
+ depends = ros-melodic-roscpp
+ depends = ros-melodic-std-msgs
+ depends = ros-melodic-sensor-msgs
+ depends = ros-melodic-geometry-msgs
+ depends = ros-melodic-nav-msgs
+ depends = ros-melodic-tf
+ depends = ros-melodic-gazebo-ros
+ source = ros-melodic-turtlebot3-gazebo-1.2.0.tar.gz::https://github.com/ROBOTIS-GIT/turtlebot3_simulations/archive/1.2.0.tar.gz
+ sha256sums = 6fbb4cf74b9777c3be3a751dd8d638df2570dd4478681b5eadf51dee32f57c5b
+
+pkgname = ros-melodic-turtlebot3-gazebo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9089dd8b4578
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+pkgdesc="ROS - Gazebo simulation package for the TurtleBot3"
+url='https://wiki.ros.org/turtlebot3_gazebo'
+
+pkgname='ros-melodic-turtlebot3-gazebo'
+pkgver='1.2.0'
+arch=('any')
+pkgrel=1
+license=('Apache-2.0')
+
+ros_makedepends=(
+ ros-melodic-catkin
+)
+
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
+
+ros_depends=(
+ ros-melodic-roscpp
+ ros-melodic-std-msgs
+ ros-melodic-sensor-msgs
+ ros-melodic-geometry-msgs
+ ros-melodic-nav-msgs
+ ros-melodic-tf
+ ros-melodic-gazebo-ros
+)
+
+depends=(
+ 'gazebo'
+ ${ros_depends[@]}
+)
+
+_dir="turtlebot3_simulations-${pkgver}/turtlebot3_gazebo"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ROBOTIS-GIT/turtlebot3_simulations/archive/${pkgver}.tar.gz")
+sha256sums=('6fbb4cf74b9777c3be3a751dd8d638df2570dd4478681b5eadf51dee32f57c5b')
+
+build() {
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}