summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242020-07-06 15:37:07 +0200
committerbionade242020-07-06 15:37:07 +0200
commit55f6b45d2d2115f5b2a0ae21a2ae028abe24058a (patch)
tree3fc2a0faa54fd417419726a9043402a1595991ae
parent832f33ff1a507b3a2697af643ea704872fce33e6 (diff)
downloadaur-55f6b45d2d2115f5b2a0ae21a2ae028abe24058a.tar.gz
Set python version to 3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08090b4094a9..62ae6830d1a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-urdf-geometry-parser
pkgdesc = ROS - Extract geometry value of a vehicle from urdf.
pkgver = 0.0.3
- pkgrel = 3
+ pkgrel = 4
url = https://wiki.ros.org/urdf_geometry_parser
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 57e62e89a471..651835a42ce0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-melodic-urdf-geometry-parser'
pkgver='0.0.3'
_pkgver_patch=0
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=3
+pkgrel=4
license=('BSD')
ros_makedepends=(ros-melodic-tf2
@@ -43,14 +43,14 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}