summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 15:05:19 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 15:05:19 +0200
commit877e9d64506eb37d021924683feea64110658909 (patch)
tree15c09bd846116ebb425a05f91bf20f1861d420a3
parent6aedfb953bef0391ccf5c5d300891f450f68ceed (diff)
downloadaur-877e9d64506eb37d021924683feea64110658909.tar.gz
Update!
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD98
2 files changed, 58 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 068931cd9632..f3ef59d4e63d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,8 +10,8 @@ pkgbase = ros-melodic-urdf-parser-plugin
makedepends = ros-melodic-catkin
makedepends = urdfdom-headers
depends = urdfdom-headers
- source = ros-melodic-urdf-parser-plugin-1.13.1-0.tar.gz::https://github.com/ros-gbp/urdf-release/archive/release/melodic/urdf_parser_plugin/1.13.1-0.tar.gz
- sha256sums = 7031baf19ed479dcc35455fc5090a740ccc28592c8fd565154ea6556aa80f747
+ source = ros-melodic-urdf-parser-plugin::git+https://github.com/ros-gbp/urdf-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-urdf-parser-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 3797a91f8b9f..c903f1efff70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - This package contains a C++ base class for URDF parsers."
url='http://ros.org/wiki/urdf'
@@ -10,52 +10,66 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- urdfdom-headers)
+ros_makedepends=(
+ ros-melodic-catkin
+)
-ros_depends=()
-depends=(${ros_depends[@]}
- urdfdom-headers)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+ urdfdom-headers
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/urdf_parser_plugin/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/urdf-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+)
-# Tarball version (faster download)
-_dir="urdf-release-release-melodic-urdf_parser_plugin-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/urdf-release/archive/release/melodic/urdf_parser_plugin/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('7031baf19ed479dcc35455fc5090a740ccc28592c8fd565154ea6556aa80f747')
+depends=(
+ ${ros_depends[@]}
+ urdfdom-headers
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/urdf-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
-
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}