summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-11-23 23:16:02 -0500
committerGitHub2019-11-23 23:16:02 -0500
commit4fae4dcab7045142dae7fe1949e076f7419b4827 (patch)
tree2ae9632f7d0a77bbf658437cae8d56f204335a0f
parent16dde9afdd50df2c09b9a36ad4261c92b7153909 (diff)
parente8111a3a33b247b29860fc2a62d7c9c9ed7de06e (diff)
downloadaur-4fae4dcab7045142dae7fe1949e076f7419b4827.tar.gz
Merge pull request #1 from jwhendy/master
updated to python3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c39e8b2fc1f4..009185ce5fa4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-warehouse-ros
pkgdesc = ROS - Persistent storage of ROS messages.
pkgver = 0.9.3
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.ros.org/warehouse_ros
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index f0f0c6cbe32b..39da7052a8bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ url='https://wiki.ros.org/warehouse_ros'
pkgname='ros-melodic-warehouse-ros'
pkgver='0.9.3'
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-melodic-tf
@@ -49,17 +49,17 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.8 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.8.so \
+ -DPYTHON_BASENAME=.cpython-38 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}