summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbionade242019-02-15 13:09:11 +0000
committerbionade242019-02-15 13:09:11 +0000
commitaf2d9943048d802254691b15b103ee50e622f902 (patch)
tree2ad1a0e325e3baf4df6dd2b137b9042d4f9a9f7e
parentacaf68808336ed1838b7fd8bcd6ee69829eed54a (diff)
downloadaur-af2d9943048d802254691b15b103ee50e622f902.tar.gz
Updated python version to 3.7
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eee567232c20..717bb52079ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-melodic-wiimote
pkgdesc = ROS - The wiimote package allows ROS nodes to communicate with a Nintendo Wiimote and its related peripherals, including the Nunchuk, Motion Plus, and (experimentally) the Classic.
pkgver = 1.12.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.ros.org/wiki/wiimote
arch = any
license = GPL
@@ -18,7 +18,7 @@ pkgbase = ros-melodic-wiimote
makedepends = ros-melodic-sensor-msgs
makedepends = ros-melodic-rospy
makedepends = cwiid
- makedepends = python2-numpy
+ makedepends = python-numpy
depends = ros-melodic-genmsg
depends = ros-melodic-std-msgs
depends = ros-melodic-roscpp
@@ -28,7 +28,7 @@ pkgbase = ros-melodic-wiimote
depends = ros-melodic-sensor-msgs
depends = ros-melodic-rospy
depends = cwiid
- depends = python2-numpy
+ depends = python-numpy
source = ros-melodic-wiimote-1.12.0-0.tar.gz::https://github.com/ros-gbp/joystick_drivers-release/archive/release/melodic/wiimote/1.12.0-0.tar.gz
sha256sums = 89cc9d0267879d69c478f2d1fafb2462142c7d462c87c9458345b76063654be8
diff --git a/PKGBUILD b/PKGBUILD
index e9b2e11160f0..6377895760c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-melodic-wiimote'
pkgver='1.12.0'
_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('GPL')
ros_makedepends=(ros-melodic-genmsg
@@ -23,7 +23,7 @@ ros_makedepends=(ros-melodic-genmsg
makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]}
cwiid
- python2-numpy)
+ python-numpy)
ros_depends=(ros-melodic-genmsg
ros-melodic-std-msgs
@@ -35,7 +35,7 @@ ros_depends=(ros-melodic-genmsg
ros-melodic-rospy)
depends=(${ros_depends[@]}
cwiid
- python2-numpy)
+ python-numpy)
# Git version (e.g. for debugging)
# _tag=release/melodic/wiimote/${pkgver}-${_pkgver_patch}
@@ -65,10 +65,10 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}