summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:22:04 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:22:04 +0200
commit4a28a593603dae8e445d8997b9f8ed1879ef2532 (patch)
treed2e49f988e8df542fcbc7d000509ffe9b4accd75
parent8f04c0c136ba60f692dde91ab22daafe0757f934 (diff)
downloadaur-4a28a593603dae8e445d8997b9f8ed1879ef2532.tar.gz
Update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD103
2 files changed, 47 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0483e8ecaa19..41ddb09ba1ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,11 +10,11 @@ pkgbase = ros-melodic-actionlib-msgs
makedepends = ros-melodic-message-generation
makedepends = ros-melodic-catkin
makedepends = ros-melodic-std-msgs
- depends = ros-melodic-message-generation
depends = ros-melodic-message-runtime
+ depends = ros-melodic-message-generation
depends = ros-melodic-std-msgs
- source = ros-melodic-actionlib-msgs::git+https://github.com/ros-gbp/common_msgs-release.git
- sha256sums = SKIP
+ source = ros-melodic-actionlib-msgs-1.12.6-0.tar.gz::https://github.com/ros-gbp/common_msgs-release/archive/release/melodic/actionlib_msgs/1.12.6-0.tar.gz
+ sha256sums = 6edb884e6ca0727fdc5c5e755a89c524ac5716b52488cb431075d33897699a95
pkgname = ros-melodic-actionlib-msgs
diff --git a/PKGBUILD b/PKGBUILD
index fc420a00212d..44b2b4ed3e61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - actionlib_msgs defines the common messages to interact with an action server and an action client."
url='http://wiki.ros.org/actionlib_msgs'
@@ -10,69 +10,54 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-message-generation
- ros-melodic-catkin
- ros-melodic-std-msgs
-)
+ros_makedepends=(ros-melodic-message-generation
+ ros-melodic-catkin
+ ros-melodic-std-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-message-runtime
+ ros-melodic-message-generation
+ ros-melodic-std-msgs)
+depends=(${ros_depends[@]})
-ros_depends=(
- ros-melodic-message-generation
- ros-melodic-message-runtime
- ros-melodic-std-msgs
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/actionlib_msgs/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/common_msgs-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/common_msgs-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="common_msgs-release-release-melodic-actionlib_msgs-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/common_msgs-release/archive/release/melodic/actionlib_msgs/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('6edb884e6ca0727fdc5c5e755a89c524ac5716b52488cb431075d33897699a95')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}