summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-08 15:14:35 +0100
committerGonçalo Camelo Neves Pereira2018-05-08 15:14:35 +0100
commit96f75a818bbfc6242fc3edec244b99045573c7f9 (patch)
tree8c466a3286b75f893d532ed116fe61b2c99ea908
downloadaur-96f75a818bbfc6242fc3edec244b99045573c7f9.tar.gz
Update
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD62
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c947e09647a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ros-melodic-bond
+ pkgdesc = ROS - A bond allows two processes, A and B, to know when the other has terminated, either cleanly or by crashing.
+ pkgver = 1.8.2
+ pkgrel = 1
+ url = http://www.ros.org/wiki/bond
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-melodic-message-generation
+ makedepends = ros-melodic-catkin
+ makedepends = ros-melodic-std-msgs
+ depends = ros-melodic-message-runtime
+ depends = ros-melodic-std-msgs
+ source = ros-melodic-bond-1.8.2-0.tar.gz::https://github.com/ros-gbp/bond_core-release/archive/release/melodic/bond/1.8.2-0.tar.gz
+ sha256sums = 202807fe60d259d78b013cea9bbe4f394726f72e4572d226edcde6e53a244ef8
+
+pkgname = ros-melodic-bond
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b02b76d74fb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - A bond allows two processes, A and B, to know when the other has terminated, either cleanly or by crashing."
+url='http://www.ros.org/wiki/bond'
+
+pkgname='ros-melodic-bond'
+pkgver='1.8.2'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-message-generation
+ ros-melodic-catkin
+ ros-melodic-std-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-message-runtime
+ ros-melodic-std-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/bond/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/bond_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="bond_core-release-release-melodic-bond-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/bond_core-release/archive/release/melodic/bond/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('202807fe60d259d78b013cea9bbe4f394726f72e4572d226edcde6e53a244ef8')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}