summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 14:48:59 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 14:48:59 +0200
commit9b7476e67ddcedad494878ec35eadbc0be735646 (patch)
treeb03c2a4ea000ed1e7c73e9c13c1a084177383da1
parent96f75a818bbfc6242fc3edec244b99045573c7f9 (diff)
downloadaur-9b7476e67ddcedad494878ec35eadbc0be735646.tar.gz
Update!
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD101
2 files changed, 60 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c947e09647a..9c57b8046671 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,8 +12,8 @@ pkgbase = ros-melodic-bond
makedepends = ros-melodic-std-msgs
depends = ros-melodic-message-runtime
depends = ros-melodic-std-msgs
- source = ros-melodic-bond-1.8.2-0.tar.gz::https://github.com/ros-gbp/bond_core-release/archive/release/melodic/bond/1.8.2-0.tar.gz
- sha256sums = 202807fe60d259d78b013cea9bbe4f394726f72e4572d226edcde6e53a244ef8
+ source = ros-melodic-bond::git+https://github.com/ros-gbp/bond_core-release.git
+ sha256sums = SKIP
pkgname = ros-melodic-bond
diff --git a/PKGBUILD b/PKGBUILD
index b02b76d74fb4..247bfa0c1c9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - A bond allows two processes, A and B, to know when the other has terminated, either cleanly or by crashing."
url='http://www.ros.org/wiki/bond'
@@ -10,53 +10,68 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-message-generation
- ros-melodic-catkin
- ros-melodic-std-msgs)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-message-generation
+ ros-melodic-catkin
+ ros-melodic-std-msgs
+)
-ros_depends=(ros-melodic-message-runtime
- ros-melodic-std-msgs)
-depends=(${ros_depends[@]})
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/bond/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/bond_core-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-message-runtime
+ ros-melodic-std-msgs
+)
-# Tarball version (faster download)
-_dir="bond_core-release-release-melodic-bond-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/bond_core-release/archive/release/melodic/bond/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('202807fe60d259d78b013cea9bbe4f394726f72e4572d226edcde6e53a244ef8')
+depends=(
+ ${ros_depends[@]}
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/bond_core-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
-
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}