summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-24 17:28:36 -0400
committeracxz2020-05-24 17:28:36 -0400
commit78bf9ac37462e2d7f2b31296bf53e663b26e2232 (patch)
treed72e7dfb2b578156268bb3f97b40eca9051998bf
parentfeff949334f3e945e36b84d7406136c3e30b6a95 (diff)
downloadaur-78bf9ac37462e2d7f2b31296bf53e663b26e2232.tar.gz
upd to noetic, cmake vars, python
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD30
2 files changed, 25 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa96b02fa971..2c6c26a2e43d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
-pkgbase = ros-melodic-camera-calibration
+pkgbase = ros-noetic-camera-calibration
pkgdesc = ROS - camera_calibration allows easy calibration of monocular or stereo cameras using a checkerboard calibration target.
- pkgver = 1.14.0
+ pkgver = 1.15.2
pkgrel = 1
url = https://wiki.ros.org/camera_calibration
arch = any
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-catkin
- depends = ros-melodic-std-srvs
- depends = ros-melodic-image-geometry
- depends = ros-melodic-cv-bridge
- depends = ros-melodic-message-filters
- depends = ros-melodic-sensor-msgs
- depends = ros-melodic-rospy
- source = ros-melodic-camera-calibration-1.14.0.tar.gz::https://github.com/ros-perception/image_pipeline/archive/1.14.0.tar.gz
- sha256sums = dcf1336d43c0c03165b76c9419fb7b5a275d0b091e1890b28daf37a02c1326b3
+ makedepends = ros-noetic-catkin
+ depends = ros-noetic-std-srvs
+ depends = ros-noetic-image-geometry
+ depends = ros-noetic-cv-bridge
+ depends = ros-noetic-message-filters
+ depends = ros-noetic-sensor-msgs
+ depends = ros-noetic-rospy
+ source = ros-noetic-camera-calibration-1.15.2.tar.gz::https://github.com/ros-perception/image_pipeline/archive/1.15.2.tar.gz
+ sha256sums = 35427b2d4e1396e0260ea2cf7d770a67104779b65fd03f287082098319c4acf5
-pkgname = ros-melodic-camera-calibration
+pkgname = ros-noetic-camera-calibration
diff --git a/PKGBUILD b/PKGBUILD
index ef1f89a814e2..609c0527fb3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgdesc="ROS - camera_calibration allows easy calibration of monocular or stereo cameras using a checkerboard calibration target."
url='https://wiki.ros.org/camera_calibration'
-pkgname='ros-melodic-camera-calibration'
-pkgver='1.14.0'
+pkgname='ros-noetic-camera-calibration'
+pkgver='1.15.2'
arch=('any')
pkgrel=1
license=('BSD')
ros_makedepends=(
- ros-melodic-catkin
+ ros-noetic-catkin
)
makedepends=(
@@ -20,12 +20,12 @@ makedepends=(
)
ros_depends=(
- ros-melodic-std-srvs
- ros-melodic-image-geometry
- ros-melodic-cv-bridge
- ros-melodic-message-filters
- ros-melodic-sensor-msgs
- ros-melodic-rospy
+ ros-noetic-std-srvs
+ ros-noetic-image-geometry
+ ros-noetic-cv-bridge
+ ros-noetic-message-filters
+ ros-noetic-sensor-msgs
+ ros-noetic-rospy
)
depends=(
@@ -34,26 +34,22 @@ depends=(
_dir="image_pipeline-${pkgver}/camera_calibration"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-perception/image_pipeline/archive/${pkgver}.tar.gz")
-sha256sums=('dcf1336d43c0c03165b76c9419fb7b5a275d0b091e1890b28daf37a02c1326b3')
+sha256sums=('35427b2d4e1396e0260ea2cf7d770a67104779b65fd03f287082098319c4acf5')
build() {
# Use ROS environment variables.
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create the build directory.
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}