summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHermann von Kleist2020-05-10 00:08:56 +0200
committerHermann von Kleist2020-05-10 00:09:38 +0200
commit389a064fca53f9dfec087401cd82b1d8ebf7b1dc (patch)
tree690b7cf487d73e8fdc5cf196095e8eb7daad5109
parent43245395221c257b806fdd25002cdaef82ddcf4b (diff)
downloadaur-389a064fca53f9dfec087401cd82b1d8ebf7b1dc.tar.gz
Ported to noetic
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1b66a964ca0..f86a5b61873a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = ros-melodic-catkin
+pkgbase = ros-noetic-catkin
pkgdesc = ROS - Low-level build system macros and infrastructure for ROS.
pkgver = 0.8.1
pkgrel = 1
@@ -16,8 +16,8 @@ pkgbase = ros-melodic-catkin
depends = gmock
depends = python
depends = ros-build-tools-py3
- source = ros-melodic-catkin-0.8.1.tar.gz::https://github.com/ros/catkin/archive/0.8.1.tar.gz
+ source = ros-noetic-catkin-0.8.1.tar.gz::https://github.com/ros/catkin/archive/0.8.1.tar.gz
sha256sums = c7b4a696fd85f7c99714c28d13409a5ed1eb87686ededa5fc80c28d4bae5d698
-pkgname = ros-melodic-catkin
+pkgname = ros-noetic-catkin
diff --git a/PKGBUILD b/PKGBUILD
index 9481c2296290..4d00ddda5221 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgdesc="ROS - Low-level build system macros and infrastructure for ROS."
url='https://www.wiki.ros.org/catkin'
-pkgname='ros-melodic-catkin'
+pkgname='ros-noetic-catkin'
pkgver='0.8.1'
arch=('any')
pkgrel=1
@@ -39,20 +39,17 @@ sha256sums=('c7b4a696fd85f7c99714c28d13409a5ed1eb87686ededa5fc80c28d4bae5d698')
build() {
# Use ROS environment variables.
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create the build directory.
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=OFF \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make