summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-07-29 23:26:10 -0400
committeracxz2020-07-29 23:26:10 -0400
commit833fba089b193518d4da0f3570c07426b22f2869 (patch)
tree4d17b72aa045ebcaedfaf7f853607fc58a75cf0a
parenta307cbdee91ca246de2fd7d8e04d44908332f015 (diff)
downloadaur-833fba089b193518d4da0f3570c07426b22f2869.tar.gz
updpkg 0.8.8
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD64
2 files changed, 35 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf6452d94c61..8bc4f91ca5d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ros-noetic-catkin
pkgdesc = ROS - Low-level build system macros and infrastructure for ROS.
- pkgver = 0.8.7
+ pkgver = 0.8.8
pkgrel = 1
url = https://wiki.ros.org/catkin
arch = any
@@ -16,8 +16,8 @@ pkgbase = ros-noetic-catkin
depends = gmock
depends = python
depends = ros-build-tools
- source = ros-noetic-catkin-0.8.7.tar.gz::https://github.com/ros/catkin/archive/0.8.7.tar.gz
- sha256sums = cffc3d336d9478cb172ec05afee3f003c6e8407076e06eb703ec39e778b2f81c
+ source = ros-noetic-catkin-0.8.8.tar.gz::https://github.com/ros/catkin/archive/0.8.8.tar.gz
+ sha256sums = bd2a5f6a445ec2c2b51d00700306fb3d23ee5f8b1875e7152074e13e6a6cf738
pkgname = ros-noetic-catkin
diff --git a/PKGBUILD b/PKGBUILD
index 8ad5fadeb19e..38814890a61b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ pkgdesc="ROS - Low-level build system macros and infrastructure for ROS."
url='https://wiki.ros.org/catkin'
pkgname='ros-noetic-catkin'
-pkgver='0.8.7'
+pkgver='0.8.8'
arch=('any')
pkgrel=1
license=('BSD')
@@ -11,50 +11,50 @@ ros_makedepends=(
)
makedepends=(
- cmake
- ${ros_makedepends[@]}
- python-catkin-pkg
- python-empy
- python
+ cmake
+ ${ros_makedepends[@]}
+ python-catkin-pkg
+ python-empy
+ python
)
ros_depends=(
)
depends=(
- ${ros_depends[@]}
- python-nose
- gtest
- python-catkin-pkg
- python-empy
- gmock
- python
- ros-build-tools
+ ${ros_depends[@]}
+ python-nose
+ gtest
+ python-catkin-pkg
+ python-empy
+ gmock
+ python
+ ros-build-tools
)
_dir="catkin-${pkgver}"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/catkin/archive/${pkgver}.tar.gz")
-sha256sums=('cffc3d336d9478cb172ec05afee3f003c6e8407076e06eb703ec39e778b2f81c')
+sha256sums=('bd2a5f6a445ec2c2b51d00700306fb3d23ee5f8b1875e7152074e13e6a6cf738')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCATKIN_BUILD_BINARY_PACKAGE=OFF \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
- -DPYTHON_EXECUTABLE=/usr/bin/python \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCATKIN_BUILD_BINARY_PACKAGE=OFF \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}